ASUS reitittimet, modeemit yms. verkkolaitteet

Viestiketju alueella 'Internet, tietoliikenne ja tietoturva' , aloittaja Tinttara, 04.02.2017.

  1. Jurppii

    Jurppii

    Viestejä:
    849
    Rekisteröitynyt:
    18.05.2017
    Dual-band kamassa tavataan esittää luku, joka on 2,4 sekä 5 GHz -taajuuksien teoreettisten kapasiteettien summa. Jos sekä tukiasema, että adapteri on dual-band, saako nuo jotenkin yhtäaikaiseen käyttöön (itselläni on eri SSID eri taajuuksien verkoissa, jotta voi priorisoida) siten, että molemmat kaistat on saman yhteyden käytössä? Vai onko tuo vain mainosmiesten kikka sanoa, että tavallaan jos molemmilla taajuuksilla olisi täysillä siirtävä laite niin tämä ja tämä olisi teoriassa mahdollista?
     
  2. mige79

    mige79

    Viestejä:
    22
    Rekisteröitynyt:
    13.01.2017
    @Hans Niskatuki Pari kertaa oon vilkuillu noita lämpöjä ja tuo 2ghz radio on siellä 54c nurkilla ja tuo 5ghz taasen molempina kertoina 61c <- lienee vielä kuitenkin tuo 60c ihan ok lukema (?) joskin aika korkeahan tuo lämpö kuitenkin jatkuvaksi lämmöksi toisaalta on. Prossun lämpöjä ei näytä tuo minun loota. En tiedä pitäskö vaiko eikö mutta lämmöistä näkyy vaan noi radiot.
     
  3. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Siis melko OK lukemat, toki hieman ehkä aavistuksen koholla. Mutta ei mitenkään pahasti Mielestäni. Katsoin juuri oman routterini 2.4 GHz lämmöt (5 Gigaa disabloituna koska käyttäjiä ei tällä hetkellä ole) ja näytti lukemaa 46 pykälää Anders Celsiuksen asteikolla mitattuna. Ambient lämmöt sen vajaat kesäiset 25 astetta. Mutta jos jotain voi päätellä, niin sanoisin että aavistuksen verran sulla koholla tuo lukema. Mutta ei Mielestäni aivan suorilta selitä sitä sun orkkis random ongelmaa.

    Ja aiemmin pistinkin ihan tarkoituksella kysymysmerkit kysymyksiini :))) koska en suoraan jaksa muistaa mitä mikäkin Asuksen routteri näyttää sen raudan osalta. Luultavasti ihan normi tilanne että aina ei kaikki lämmöt tms. näy GUI:ssa.
     
  4. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Ja vielä käyttäjälle @mige79 sellainen vinkki että ketjuun postaamani aiemman viestin #48 ohjeita orjallisesti noudattaen otat ne routterin asetukset jemmaan (screen capturet ja copypastet notepadiin) ja teet sen factory resetin. Ja fresh start from scratch. Ehkä myös tuorein firmis (beta) tulille sitä ennen.

    Tiätty, on se vähän turhauttavaa toimintaa naputella niitä asetuksia uusiksi. Mutta kun asennoidut oikein ja kepein Mielin niin ei se ole paha rasti mitenkään. Vienee vain sen tunnin tai pualtoista about laatuajastasi, mutta hyvinkin pitkälti poissulkee monta tekijää (=rautavika).
     
  5. mige79

    mige79

    Viestejä:
    22
    Rekisteröitynyt:
    13.01.2017
    Jees pitää kattella josko tuohon joskus jaksaisi ryhtyä. Toisaalta noiden asetusten talteenotto voisi olla sikälikini järkevää että jos vaikka joskus reititintä vaihtaa niin saisi sitten tarkisteltua nuo jostain ettei tartte netistä ruveta kaivelemaan.
    Kuitenkin nuo laitteiden resetoinnit on edelleen musta vähän niin ja näin. Onhan esim. windows koneetkin nykyään aikalailla huoltovapaita jos nyt ei ihan isosti rupea säätämään niiden kanssa ja kohtuullisista osista koneen kasaa niin luulis nyt tuommoinen yhtä asiaa varten rakennettu purkki saatavan jotakuinkin vakaasti toimimaan.
    Olen mm. hommannut erillisen serverinkin kun ei noista pikkupurkeista ole mihinkään nas-hommiin tai paljon muuhunkaan ylimääräiseen.
    Noh meni jo OT:ksi vähäsen....
     
  6. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Tuollainen utilityhän on olemassa. En nyt ehdi sen enempiä keskustelemaan aiheesta mutta tuossa triidissä on kaikki oleellinen tieto ja kikkareen zipissä hyvät käyttöohjeet:

    User NVRAM Save/Restore Utility (R24a)
     
  7. damii

    damii

    Viestejä:
    3
    Rekisteröitynyt:
    14.08.2017
    Mulla on sama purkki ja nyt oon kiinnittänyt huomiota ihan samaan asiaan. Mulla vika on varmasti Asuksen tukarissa, koska kaikilta laitteilta (oma läppäri, lasten tietokoneet yms.) häviää tukari näkyvistä. Joskus WLANit palaa toimintaan itsestään, joskus joutuu resetoimaan purkin. Aiemmin mulla on ollut Merlin purkissa sisässä, mutta nyt vaihdoin kokeeksi Asuksen oman uusimman firmiksen. Tekee sitä samaa molemmilla. Täytyy tehdä tuo factory reset tuolle vielä huomenna ja seurata miten jatkaa toimintaa.
     
  8. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Merlinin tuorein beta toimii melko buenosti. Kannattaa ajaa se sisään.
    Download | Asuswrt-Merlin
     
    damii tykkää tästä.
  9. Stanley H. Tweedle

    Stanley H. Tweedle

    Viestejä:
    623
    Rekisteröitynyt:
    18.10.2016
    Kannattaa aina vetää hard reset 30-30-30 -menetelmällä:

    Hard reset or 30/30/30 - DD-WRT Wiki

    Firmikset, myös alkuperäiset jättävät tauhkaa nvramiin ja se saattaa aiheuttaa epämääräisiä ongelmia.
     
  10. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Paitsi että eipäehkä kannata. :geek:

    Tuo 30-30-30 on aikansa elähtänyt myytti ja legenda noin vuodelta miekka ja kilpirauhanen eikä päde enää. Joten unohtakaa se viimeistään nyt. hehe
     
  11. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Hankin uuden mokkulan viime talvena itsekseen sammuilevan vanhan mokkulan tilalle. Tuo uusi mokkula on Huawei E5377. Huomasin siinä olevan todella huono wlan kantama ja signaali ja kerran jo kävin vaihtamassa laitteen uuteenkin mutta homma ei parantunut. Ajattelin siis hankkia huonolla perehtymisellä jonkun laitteen jolla voisin jakaa mokkulan netin laitteille paremmalla kantamalla. Ja tuoksi laitteeksi valitsin Asus RT-N14U:n.

    Kuvat nykyisestä ja toivotusta tilanteesta:
    Nykytila Dropbox - nykytila.jpg
    Tavoite Dropbox - tavoitetila.jpg

    En osannut laittaa kuvia suoraan näkyville mutta noista linkeistä atk-foorumilaiset selvinnevät.

    Asuksen sivujen mukaan tuo mokkula ei sitten olekaan tuettu ja vakiofirmiksellä olen tuon käytännössä todennut (tai sitten en vaan osannut). Löysin ohjeet (The Blog of Juho) joiden mukaan tuo pitäisi saada toimimaan. Olen hukannut kaikki usb A piuhani johonkin eli tuota ohjeen ensimmäistä kahta vaihetta en ole tehnyt vielä. Niiden jälkeen pitää vissiin siirtyä usb:stä ethernetiin? Päivitys tähän: Olin ymmärtänyt väärin, mokkula liitetään Asukseen usb:llä, sitten ethernetin yli ssh:lla katsellaan OpenWRT:n näkemät usb-laitteet.

    Asukseen olen saanut taiteiltua OpenWRT 15.05 jakelun, joka vielä oli yksinkertaiselle miehelle riitävän yksinkertaista. Pitäisi vaan saada paketteja asennettua
    Koodi:
    opkg install usb-modeswitch usb-modeswitch-data kmod-usb-net kmod-usb-net-cdc-ether
    mutta mulla ei kai voi olla samaan aikaan nettiyhteyttä kun olen ethernet-piuhalla kiinni tuossa asuksessa. Nyt tulee sellainen asia josta en ole ihan varma olenko ymmärtänyt oikein: Mun pitäisi siis ilmeisesti löytää nuo paketit usb-modeswitch usb-modeswitch-data kmod-usb-net kmod-usb-net-cdc-ether jostain, siirtää ne vaikka Asusin /tmp -hakemistoon ja asentaa sieltä (ottaa mallia How to install Luci without internet connection (Page 1) — General Discussion — OpenWrt). koska ilman nettiä en voi asentaa suoraan reposta. Jos olen hoksannut kuvion oikein niin seuraava kysymys tietysti on että mistä löydän oikeat versiot noista paketeista?

    SSH-yhteydet Asusiin toimii ihan ok ja sen suhteen ei ole ongelmaa, ainoa hankaluus on tosiaan se että ainoa netti tulee tuon mokkulan kautta joka ei pelaa tuon Asusin kanssa ennen kuin nuo paketit on asennettu ja tehty jotkin muut tepposet.


    En oikein osannut kiteyttää ongelmaani mutta toivottavasti tästä saa jollain lailla kuvan tilanteestani. Ja lisätietoja annan mielelläni, kun vain tiedän mitä tietoja tarvitaan. Kiitos kaikille jotka tämän jaksavat lukea ja ennen kaikkea vastailla.


    Päivitystä: Paketteja lataillessa törmäsin siihen, että en meinaa löytää usb-modeswitch-data:a. Sitä ei vissiin enää käytetä vaan se tulee jo usb-modeswitch-data:ssa. Lähde: #13684 (usb-modeswitch-data package missing) – OpenWrt
     
    Viimeksi muokattu: 20.08.2017
  12. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Nämä paketit piti siis asentaa:
    Koodi:
    kmod-mii
    kmod-usb-net
    kmod-usb-net-cdc-ncm
    kmod-usb-wdm
    libpthread
    librt
    libusb-1.0
    kmod-usb-net-cdc-ether_3.18.20-1_ramips_24kec.ipk
    kmod-usb-net-huawei-cdc-ncm_3.18.20-1_ramips_24kec.ipk
    usb-modeswitch_2014-08-26-993a9a542791953c4804f7ddbb3a07756738e37a_ramips_24kec.ipk
    
    Tässä kohtaa mulla tulee joku pulma:
    Koodi:
    root@OpenWrt:/tmp# opkg install usb-modeswitch_2014-08-26-993a9a542791953c4804f7ddbb3a07756738e37a_ramips_24kec.ipk
    Installing usb-modeswitch (2014-08-26-993a9a542791953c4804f7ddbb3a07756738e37a) to root...
    Configuring usb-modeswitch.
    root@OpenWrt:/tmp# usb_modeswitch -v 12d1 -p 1f02 -M 55534243123456780000000000000a11062000000000000100000000000000
    -ash: usb_modeswitch: not found
    root@OpenWrt:/tmp#
    
    Kokeilin vaihtaa alaviivan väliviivaksi mutta ei onnea:
    Koodi:
    root@OpenWrt:~# usb-modeswitch -v 12d1 -p 1f02 -M 55534243123456780000000000000a11062000000000000100000000000000
    -ash: usb-modeswitch: not found
    
    us tabilla täydennettynä tarjoaa vaihtoehdot
    Koodi:
    root@OpenWrt:~# us
    usbmode  usign
    
    Jotakin yksinkertaista mä nyt tässä tuon usb-modeswitchin kanssa kädetän mutta mitä? Kirjoitusvieheistä ei pitäisi olla kyse koska kopioin ja liitän tai käytän tab-completea komentojen kanssa.

    Muokkaus: dmesg output spoileriin:
    [ Vain rekisteröityneet käyttäjät näkevät Spoiler-tagin sisällön. Rekisteröidy foorumille... ]

    Juho Tykkälän blogipostauksessa sanotaan että
    At /sys/kernel/debug/usb/devices before mode-switch descriptors are:
    Koodi:
    Vendor=12d1 ProdID=1f02 Rev= 1.02

    Mun /sys/kernel/debug/usb/devices tulosteesta en löydä mode-switch descriptor riviä:
    [ Vain rekisteröityneet käyttäjät näkevät Spoiler-tagin sisällön. Rekisteröidy foorumille... ]
     
    Viimeksi muokattu: 20.08.2017
  13. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    @apoiuyt
    Oletkos katsonut mitä tuo usb-modeswitch paketti asentaa ja minne?
     
    apoiuyt tykkää tästä.
  14. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
  15. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Toi paketti on muuten sen verran vanha että se ei taida sopia 15.05 :lle :facepalm: Pitäisi siis löytää oikealle arkkitehtuurille ja OpernWRT:n versiolle oleva paketti.
     
  16. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Tämäkin vielä. Mutta pikaisesti kurkattuna tuosta paketista näyttäisi asentuvan (/sbin/)usbmode usb-modeswitchin sijaan.
     
    apoiuyt tykkää tästä.
  17. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Kiitos. Nyt on otettava lusikka kauniiseen käteen ja mentävä työmaalle, jossa saan kytkettyä Asusin ethernetillä internetiin. Pitää vaan odottaa että rouva tulee kaitsemaan noita kupeideni hedelmiä kun ei niiden avusta tähänkään asti ollut paljoa apua. Pakko vaan myöntää ettei tuo pakettien ja riippuvuuksien asentaminen käsin ole mun vahvuuksia.

    Taidan ensin sipaista laatikon puhtaalle asennukselle ettei jää näitä vanhoja häntiä kiusaamaan uutta asennusta.
     
  18. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Itseasiassa, nyt kun katsoin tuota linkkiäsi tarkemmin niin ainakin tuo näyttäisi viittaavan 15.05:een. Ja OpenWRT:n RT-N14U wikisivun perusteella arkkitehtuurikin natsaa. Mutta helpompihan tuo olisi jos saat koneen internetin päähän siksi aikaa että asentelet tarvittavat kamppeet.

    Ei tuo OpenWRT ole niin tuttu itselle, olen toistaiseksi pitäytynyt AsusWRT:ssä (joskin Merlinin versiossa kun oma Asukseni on tuettuna sen puolesta), niin en oikeastaan mitään rakentavampaa neuvoa osaa tarjota.
     
  19. mustekylpy

    mustekylpy

    Viestejä:
    236
    Rekisteröitynyt:
    24.02.2017
    Voit myös kokeilla yhdistää tietokoneen mokkulalla nettiin ja jakaa sen yhteyden johdolla reitittimeen. Pitäisi käsittääkseni onnistua Windowsin verkkoyhteyksistä, kun valitsee sekä ethernetin että tuon mokkulaan olevan yhteyden, oli se sittene usb tai wifi, ja oikealla napilla laittaa siltauksen niiden välille.
     
    apoiuyt tykkää tästä.
  20. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Kiitos, siltaus onnistui. Koska mulla on vain 1 Ethernet-liitin läppärissä, pitäisi Asusiin vissiin yhdistää wlanilla. Katsoin ipconfigista ja nyt sekä sillan että wlanin default gateway on 192.168.1.1 ja tuo osoite vie mokkulan hallintasivulle. Kokeilin selaimen yksityinen tila toiminnolla, jotta historia ei hämäisi. Miten tästä pääsisi eteenpäin?
     
  21. mustekylpy

    mustekylpy

    Viestejä:
    236
    Rekisteröitynyt:
    24.02.2017
    Gateway saa varmaan mokkula ollakin, periaatteessa Asuksen pitäisi saada mokkulalta oma ip ja kone on vain siltana välissä. Käsittääkseni tuota wlan-yhteyttä ei edes tarvitseisi, vaan laitteet on jo mokkulan kautta samassa verkossa. Voit kokeilla summassa jotain 192.168.1.10x jos mokkula ei listaa yhdistettyjä laitteita.
     
    Viimeksi muokattu: 20.08.2017
    apoiuyt tykkää tästä.
  22. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Yritin vielä tuota siltausta mutta en keksinyt mistä olisin nähnyt minkä ip-osoitteen mokkula antaa Asusille. Kokeilin kymmenkunta ensimmäistä 192.168.1.1 eteenpäin mutta ei tärpännyt. 6. kohdalla luulin jo osuneeni mutta Putty ei siihen yhdistänyt.

    Annan siltauksen jäädä tällä haavaa sikseen ja menen käväisemään työpaikalla kytkemässä ethernetin wan-porttiin.
     
  23. mustekylpy

    mustekylpy

    Viestejä:
    236
    Rekisteröitynyt:
    24.02.2017
    Tuossa edellisessä viestissä oli pieni kirjoitusvirhe. DHCP-osoitteet tulee yleensä 192.168.1.100 eteenpäin. Toisaalta Asukselle voi myös käydä ensin laittamassa kiinteän ip:n jonka arvelee olevan vapaana, esim 192.168.1.69 ja sitten kytkee taas siltaan.
     
  24. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 287
    Rekisteröitynyt:
    19.10.2016
    Koodi:
    # usbmode --help
    usbmode: unrecognized option: -
    Usage: usbmode <command> <options>
    Commands:
        -l        List matching devices
        -s        Modeswitch matching devices
    
    Options:
        -v        Verbose output
        -c <file>    Set configuration file to <file> (default: /etc/usb-mode.json)
    Tuo usbmode taitaa olla oikea työkalu, mutta sen syntaksi on eri kuin usb-modeswitchin ja se vaatii asetukset json muodossa tiedostosta.

    Use 3g/UMTS USB Dongle for WAN connection [OpenWrt Wiki]

    Katso tuolta ohjeita.
     
    apoiuyt tykkää tästä.
  25. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Tänään vasta pääsin käymään työmaalla ja piuhan kanssa asensin paketit. Netti toimi moitteetta. Nyt illemmalla olen koittanut tuon Juhon blogin (The Blog of Juho) ohjeita seurailla ja lisäsin /etc/usb-mode.json -tiedostoon rivit heti ensimmäiseksi laitteeksi
    Koodi:
    "12d1:1f02": {
       "*": {
          "t_vendor": 4817,
          "t_product": [ 5339 ],
          "mode": "HuaweiNew",
          "no_driver": true,
          "msg": []
        }
      }
    
    Tuo modeswitch vissiin joutaa kokonaan romukoppaan. Ainakaan en saanut tehtyä tiedostoa nimeltä
    /etc/usb_modeswitch.d/12d1:1f02. Ei vaan suostunut. Tietokoneella sain sen tehtyä mutta reititin ei suostunut ottamaan sitä vastaan scp-komennolla. Veikkaan että tuossa nimessä joku haraa vastaan. Sekin on jäänyt mietityttämään, että kun en saa läpi tuota komentoa
    Koodi:
    usb_modeswitch -v 12d1 -p 1f02 -M 55534243123456780000000000000a11062000000000000100000000000000
    
    niin sitten dmesg -tulosteessa ei näy rivejä
    Koodi:
    usb 1-1: usbfs: process xxxx (usb_modeswitch) did not claim interface 0 before use
    usb 1-1: USB disconnect, device number xx
    Olen nyt buuttaillut Asusta ja kerran tietokoneenkin ja koittanut sekä langalla ensimmäisestä ethernetportista (ei van!) että wlanin yli mutta nettiin asti en pääse mokkula kiinni reitittimen usb-portissa. Vissiin pitäisi tuolle modeswitchille jotain saada tehtyä.

    @Pertti Kosunen antamasta linkistä bongasin maininnan
    Yritin rimpsuilla
    Koodi:
    service usbmode
    ja
    Koodi:
    service --status-all
    mutta servicea ei ole asennettuna systeemiin. Tein
    Koodi:
    /etc/init.d/usbmode enable
    jotta se nyt sitten olisi ainakin käynnissä. Reitittimen boottauksen jälkeenkään ei nettiä.


    Onko kellään enää ideoita vai onko se lampsittava ostamaan joku B593 tai mitä ne uudemmat nyt ovatkaan?
     
  26. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Tai kannattaisiko etsiä vanhempi versio OpenWRT:stä ja asentaan se :beye:
     
  27. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 287
    Rekisteröitynyt:
    19.10.2016
    Kokeile laittaa "12d1:1f01" ja "12d1:1f03" laitteiden väliin, json toimivuus saattaa olla pienestä kiinni. Poistamalla ja uudelleenasentamalla modeswitch paketin saanee /etc/usb-mode.json tiedoston alkuperäiseen tilaan.

    Koodi:
            "12d1:1f01": {
                "*": {
                    "t_vendor": 4817,
                    "t_product": [ 5339, 5340 ],
                    "mode": "HuaweiNew",
                    "no_driver": true,
                    "msg": [  ]
                }
            },
            "12d1:1f02": {
                "*": {
                    "t_vendor": 4817,
                    "t_product": [ 5340 ],
                    "mode": "HuaweiNew",
                    "no_driver": true,
                    "msg": [  ]
                }
            },
            "12d1:1f03": {
                "*": {
                    "t_vendor": 4817,
                    "t_product": [ 5339 ],
                    "mode": "HuaweiNew",
                    "no_driver": true,
                    "msg": [  ]
                }
            },
    Huawei E5377 toimimaan OpenWRT:n kanssa USB piuhalla - Elisa Palsta

    Liekö väliä, mutta tuolla neuvotaan "t_product": [ 5340 ].
     
    apoiuyt tykkää tästä.
  28. Ryydike

    Ryydike

    Viestejä:
    713
    Rekisteröitynyt:
    04.11.2016
    apoiuyt tykkää tästä.
  29. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Tarjoaako Lede parempaa tukea mokkuloille? Lukaisen vielä illemmalla lisää tuosta Ledestä jos vaikka saisin selviteltyä itselleni sen olennaiset erot OpenERT:n.
     
  30. Ryydike

    Ryydike

    Viestejä:
    713
    Rekisteröitynyt:
    04.11.2016
    Itse LEDE on forkattu OpenWRT:stä ja sitä kehitetään aktiivisemmin verrattuna OpenWRT:hen joten tuki mokkuloille on sama tai parempi. Itsellä pyörii reitittimessä LEDE extroot asennettuna ja oma mokkulakin tunnistuu ja toimii.
     
  31. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Ai niin, unohdin mainita että kokeilin siirtää laitteen paikkaa asetustiedostossa usb-mode.json sekä vaihdoin sitten myös numeron 5339 -> 5340. Ei lykästänyt vieläkään.

    Seuraavat askelet mulla onkin vanhemman OpenWRT:n kokeileminen ja jos ei silläkään toimi niin kokeilen Ledeä. Leikin nyt ensin tämän OpenWRT:n kanssa.
     
  32. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 287
    Rekisteröitynyt:
    19.10.2016
    Laita tikku johonkin tietokoneeseen ja tarkista mitkä USB vendor ja product id:t on siinä tilassa missä netti toimii.
     
    apoiuyt tykkää tästä.
  33. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Tietokoneella dmesg:
    Koodi:
    8.626307] usb 2-1.2: new high-speed USB device number 6 using ehci-pci
    [    8.735454] usb 2-1.2: New USB device found, idVendor=12d1, idProduct=14dc
    [    8.735460] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [    8.735461] usb 2-1.2: Product: HUAWEI_MOBILE
    [    8.735473] usb 2-1.2: Manufacturer: HUAWEI_MOBILE
    
    idVendor=12d1, idProduct=14dc on sama kuin tuolla Juho Tykkälän blogitekstissä modeswitchin jälkeen nähty tuloste /sys/kernel/debug/usb/devices.

    Muutin usb-mode.json tiedostoon muuttuneet id:t ja siirsin osion 12d1:14d1 ja 12d1:14fe väliin. Ei nettiä. Sitten sinne HuaweiNew:n tilalle HUAWEI_MOBILE tuohon osioon. Ei auttanut.


    Pitäisi vissiin varmistaa että tämä
    Koodi:
    /etc/usb_modeswitch.d/12d1:1f02
    starttaa buutissa. Mitenkähän se tehdään?
     
  34. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Onko sinulla tuo message usb-mode.jsonissa, ja tuo laitteen msg-kenttä osoittamassa oikeaa messagea?

    Edit:

    Olisko tästä apua, vaikka tuo ilmeisesti onkin jollekin OpenWRT johdannaiselle mutta näyttäisi käyttävän samaa json-pohjaista usbmodea.
     
    Viimeksi muokattu: 23.08.2017
    apoiuyt tykkää tästä.
  35. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Mä vasta nyt tajusin mitä se meinaa. Joskus on ollut numero 28 ja joskus ollut tyhjä. Tarkastan huomenna millä rivillä on oikea message, jos siis se toimii kuten oletan eli messageen laitetaan rivin numero.
     
  36. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Se on luultavasti viestin indeksi (ensimmäinen = 0).

    Jos et huomannut, kävin ninjailemassa linkin tuohon aikaisempaan viestiini, saattaa saada ainakin jotakin vinkkiä jos ei suoraan auttaisikaan.
     
    Viimeksi muokattu: 24.08.2017
    apoiuyt tykkää tästä.
  37. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 287
    Rekisteröitynyt:
    19.10.2016
    Koodi:
    mv /etc/usb-mode.json /etc/usb-mode.json.bak
    nano /etc/usb-mode.json
    Koodi:
    {
            "messages" : [
                    "55534243123456780000000000000a11062000000000000100000000000000",
    ],
    "devices" : {
                    "12d1:1f02": {
                            "*": {
                                    "t_vendor": 4817,
                                    "t_product": [ 5340 ],
                                    "no_driver": true,
                                    "msg": [ 0 ]
                            }
                    },
            }
    }
    Kokeile varmistaa usb-mode.json tiedosto ja pelkästään tuolla json pätkällä, alkuperäisestä oikean message rivin metsästys menee hankalaksi.

    ( OpenWrt / ROOter multi-WAN with Huawei E5377, Linksys E3000 )
     
    apoiuyt tykkää tästä.
  38. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017

    Koitin tuota ensimmäiseksi mutta tuolla en saanut mokkulaa tunnistumaan dmesg:ssa jos oikein katsoin.


    Pistin sitten usb-mode.json -tiedostoon messagen 56. riville messageja ja laitteen tietoihin "msg":[ 55 ]. Sillä saatoin päästä vähän eteenpäin:
    Koodi:
    root@OpenWrt:~#  usbmode -l
    Found device: 12d1:14dc (Manufacturer: "HUAWEI_MOBILE", Product: "HUAWEI_MOBILE", Serial: "")
    root@OpenWrt:~# usbmode -s -v -c /etc/usb-mode.json
    Failed to send switch message
    root@OpenWrt:~#
    Eli mokkula tunnistuu tunnuksella, joka loppuu 14dc. Siitä tulkitsen että mode on vaihtunut. Pitäisiköhän tuossa Serialissa olla joku luku? Siirsin lopuksi vielä tuon rivin yhden pykälän ylemmäs ja muutin msg:n 54:ksi koska silloin se message meni aakkosjärjestyksessä oikeaan kohtaan.

    Linkistä (OpenWrt / ROOter multi-WAN with Huawei E5377, Linksys E3000) luin, että tällaista pitäisi löytyä jos vaihto onnistui:
    Koodi:
    dmesg
    [   12.800000] cdc_ether 1-1:1.0 eth1: register 'cdc_ether' at usb-101c0000.ehci                                                                                                                                                -1, CDC Ethernet Device, 0c:5b:8f:27:9a:64
    Ninjaedit: tämä on siis mun purkista otetusta litaniasta eli vaikuttaisi olevan ok.

    Tätä en tajua:
    En vain tiedä mitä tässä kohtaa pitäisi tehdä.
     
  39. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 287
    Rekisteröitynyt:
    19.10.2016
    Liekö helpointa vaihtaa /etc/config/network tiedostosta vanha eth? 'wan' alta eth1:ksi.
     
    apoiuyt tykkää tästä.
  40. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Muutin tuon eth0.2 -> eth1 mutta en buuttaujenkaan jälkeen saanut vielä nettiä pelaamaan.

    Nyt /etc/config/network näyttää tältä:
    [ Vain rekisteröityneet käyttäjät näkevät Spoiler-tagin sisällön. Rekisteröidy foorumille... ]

    Kyllä osaakin olla vaikeaa. Pitää koittaa vielä lueskella aiheesta. Toi laite on päässy vähän ihon alle.
     
  41. apoiuyt

    apoiuyt

    Viestejä:
    90
    Rekisteröitynyt:
    18.01.2017
    Luovutin tämän osalta ja ostin ethernet-portilla varustetun mokkulan (Huawei B315). Onneksi tälle ehkä löytyy käyttöä jos tarvii sähköpiuhoja pitkin laajentaa verkkoa. Tai jos reitittää liikenteen tykkänään tällä, riippuu siitä millainen vehje se uusi tulokas on.

    Ai niin kiitokset avusta, harmi kun vastaanottava pääty ei tällä kertaa yltänyt vaadittavaan suoritukseen.
     
  42. Ruohonjuuri

    Ruohonjuuri

    Viestejä:
    5
    Rekisteröitynyt:
    23.07.2017
    Tuli hankittua RT-AC3200 (kun halvalla sai).

    Tarkoitus olisi laittaa se valokuidun perään omakotitalossa jakamaan langatonta. Laitteita tulee olemaan kiinni varmaan kymmenkunta (perheen kännykät, tabletit yms.) - teinien youtubeilu on melko intensiivistä. Tarve olisi myös vierasverkolle. Olisi hyvä jos kantama riittäisi pihalle kun (n.20m+seinät/ikkunat), mutta luotettava toiminta on tärkeämpää.
    Kiinteille laitteille on kaapelointi.

    Millaista firmistä suosittelette?
    Kannattaako mennä valmistajan omalla, vai onko hyviä perusteluja miksi ajaisi sen yli vaikka Tomatolla tai jollain muulla?
     
  43. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Tuorein Merlin tulille vaan.

    [Release] Asuswrt-Merlin 380.68 is available

    Download | Asuswrt-Merlin

    Muistaakseni routterisi osalta Merlinin firmis näyttää laniportit väärässä järjestyksessä johtuen kai Asuksen omasta koodista. Mutta tuo bugi ei haittaa kuin kosmeettisesti.

    edit: Ja sitten kun olet saanut purkin säädöt kuosiin niin seivaa ne usbitikulle NVRAM Save/Restore Utilityllä:
    User NVRAM Save/Restore Utility (R26.0)
     
    Viimeksi muokattu: 07.09.2017
  44. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Juuri tämä, Merlin koneeseen ja kovaa ajoa.
     
  45. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Tuli vielä Mieleeni että mikäli purnukassa sattuisi olemaan joku ihan aataminaikuinen firmis niin välttis tämä uusin Merlin ei asennu ihan heittämällä koska koodiin on tullu kaikenlaista muutosta huru mycket. Mikäli päivitettäessä herjaa jotain tuohon viittaavaa tai firmware ei asennu niin sitten vaan joku tuore Asuksen oma firmis sisään välimallina ja siitä sitten päivitys Merliniin. Ja firmistä päivitettäessä kaikki usbitikut (mikäli sellaisia on kytkettynä) irti laitteen perseestä. Ne saattavat estää päivityksen onnistumisen.

    Factory Reset kannattaa toki tehdä heti päivityksen jälkeen ja naputella säädöt käsin from scratch mikäli firmisten päivitys tehdään suurin versionumerokohtaisin hyppäyksin.

    Sitten kun uusin Merlin on asennettu niin jatkossa tuoreet päivitykset menevät lähes poikkeuksetta sisään ihan ongelmitta ja Factory Resettiä ei tarvitse suorittaa (mikäli mitään ongelmia ei ole).
     
  46. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Toki jatkossa kannataa ennen päivitystä lukaista changelog läpi, myös niiltä versioilta jotka on nykyisen ja päivityksen välissä. Vähintään ne IMPORTANT kohdat, muistan ainakin yhden kerran kun on pitänyt päivityksen jälkeen tehdä factory reset ja palauttaa käsin asetukset ongelmien välttämiseksi, ja tästä varoittiin aika selkeästi.
     
  47. Ruohonjuuri

    Ruohonjuuri

    Viestejä:
    5
    Rekisteröitynyt:
    23.07.2017
    Kiitos!
    Mikä tuosta Merlinistä tekee killerin yli muiden kilpailevien tai Asuksen firmiksen? Stabiilimpi, tehokkaampi, paremmat ominaisuudet vai mikä? Eikös Asuksella ainakin ollut se Smart Connect (mistä ainakin alussa oli enemmän haittaa kuin hyötyä). Löytyykö vastaava myös Merlinistä?
     
  48. Barbarossa

    Barbarossa

    Viestejä:
    130
    Rekisteröitynyt:
    17.10.2016
    Merlin on melko pitkälle Asuksen oma firmware (johon se pohjautuukin) mutta siitä on korjattu ongelmia joita ei viralliseen softaan ole välttämättä (vielä) korjattu, ja tehty pieniä viilauksia sinne tänne. Merlinin Asuswrt-sivuilta löytyy tarkempi kuvaus.
     
  49. Ruohonjuuri

    Ruohonjuuri

    Viestejä:
    5
    Rekisteröitynyt:
    23.07.2017
    No niin tuoltajan se hyvin selvisi kun sivuilta kävi lukemassa. Tämähän on aika selkeä homma, Merlin valittu. Kiitos avusta!
     
  50. Hans Niskatuki

    Hans Niskatuki

    Viestejä:
    178
    Rekisteröitynyt:
    16.10.2016
    Tuo aiemmin mainitsemani bugi on muuten tuoreimmassa versiossa (380.68_2) fixattu:

    @Ruohonjuuri