Linux kysymyksiä

Viestiketju alueella 'Yleinen ohjelmistokeskustelu' , aloittaja nanob, 17.10.2016.

  1. Asiantuntija

    Asiantuntija

    Viestejä:
    317
    Rekisteröitynyt:
    19.10.2016
    Vai onko se ethernet interfacen nimi edes eth0? Uudemmissa asennuksissa tulee välillä nimiksi enp4s0 tai enp2s0 tyylisiä. Kannattaa tarkistaa terminaalista kirjoittamalla ifconfig.
     
    karhukopla tykkää tästä.
  2. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017
    Joo nyt ymmärsin, luin väärin. Siis tuohon /etc/issue.net , sinne kirjoitetaan viesti.

    Kirjoitin sinne:

    -------Welcome------
    ------Student----------

    sitten tallensin ja kirjoitin terminaaliin:
    sudo service ssh reload


    Nyt kun puttylla yhdistän, niin en näe viestiäni.
    Lukeekohan ssh sen viestin muualta?
    Minulla lukee myös tuo Ubuntu 16.04.2Lts, tuossa tiedostossa.
     
    Viimeksi muokattu: 20.03.2017
  3. user9999

    user9999 Premium-jäsen Team Apple

    Viestejä:
    197
    Rekisteröitynyt:
    17.10.2016
    Itsellä esim. ubuntu 16.04 serverissä juuri enp2s0 tyylisiä:

    Koodi:
    auto enp2s0
    iface enp2s0 inet static
     
    karhukopla tykkää tästä.
  4. copter

    copter Last Man Standing Premium-jäsen

    Viestejä:
    1 351
    Rekisteröitynyt:
    05.12.2016
    Kirjoita komento "sudo ifconfig -a" ja laita outputti tänne niin nähdään.
     
    karhukopla tykkää tästä.
  5. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017
    Siinä lukee näin ja yhä kamppailen tuon ssh ja staattisen ip laiton kanssa.

    enp3s0 Link encap:Ethernet HWaddr bc:ee:7b:59:09:9e
    inet addr:192.168.1.231 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::bc96:429c:55b3:5b01/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:74839 errors:0 dropped:86 overruns:0 frame:0
    TX packets:34194 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:74030947 (74.0 MB) TX bytes:5515498 (5.5 MB)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:12085 errors:0 dropped:0 overruns:0 frame:0
    TX packets:12085 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:1171742 (1.1 MB) TX bytes:1171742 (1.1 MB)
     
  6. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Onko sulla selvillä sun verkon gatewayn osoite?
     
    karhukopla tykkää tästä.
  7. copter

    copter Last Man Standing Premium-jäsen

    Viestejä:
    1 351
    Rekisteröitynyt:
    05.12.2016
    Noniin. Eli siis verkkokortin nimi ei ole eth0 vaan enp3s0. Korvaa siis kaikki eth0 merkinnät tuolla ja kokeile uudelleen käynnistää verkko.

    EDIT: Siis siitä /etc/network/interfaces tiedostosta
     
    karhukopla tykkää tästä.
  8. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017
    kirjoitin nyt siis:

    """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
    # interfaces(5) file used by ifup(8) and ifdown(8)

    auto lo
    iface lo inet loopback
    auto enp3s0
    iface enp3s0 inet static
    address 192.168.1.88
    netmask 255.255.255.0
    gateway 192.168.1.1

    """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

    Koitin vielä käynnistää uudelleen:
    /etc/init.d/networking restart

    Sain sen vihdoin näyttämään staattista osoitetta.
    Kokeilin irroittaa sen ethernet johdon koneen takaa ja sitten pistää hetken kuluttua uudelleen.

    Nyt vielä puuttuu se ssh motd, eli welcome message.
     
  9. Asiantuntija

    Asiantuntija

    Viestejä:
    317
    Rekisteröitynyt:
    19.10.2016
    Koita "sudo service network-manager restart" tai "sudo service networking restart" tai viimisenä vaihtoehtona "sudo ifdown enp3s0 && sudo ifup enp3s0", mutta tuossa on vaarana, että ssh-yhteys katkeaa ennen ifup komentoa ja koko interface jää alas eikä nouse kuin virtanapista reboottaamalla. Jos kyseessä siis headless purkki.
    e: näköjään ratkaistu jo. Hidas.
     
    karhukopla tykkää tästä.
  10. nnaku

    nnaku I'm object-oriented! Premium-jäsen

    Viestejä:
    286
    Rekisteröitynyt:
    28.11.2016
    mun error... Banneri tulee siis heti käyttäjätunnuksen jälkee.. enne salasanaa...
    salasanan järkeen tuleva viesti tulee laittaa tänne

    Kirjoita viesti tänne,
    Koodi:
    sudo nano /etc/motd.tail
    ja lisää tämä rivi
    Koodi:
    session    optional   pam_motd.so  motd=/etc/motd.tail
    tämän tiedoston loppuun.
    Koodi:
    sudo nano /etc/pam.d/sshd
    
    [ Vain rekisteröityneet käyttäjät näkevät Spoiler-tagin sisällön. Rekisteröidy foorumille... ]
     
    Viimeksi muokattu: 20.03.2017
    karhukopla tykkää tästä.
  11. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017

    Siis kun kirjoitat terminaaliin:

    sudo -i
    putty

    Kirjaudut puttylla ssh yhteyteen, niin miten saa tämmöisen tekstin vaihdettua:

    """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

    Welcome to ubuntu 16.04.2LTS (GNU/Linux 4.8.0-41-generic x86_64)

    * Documentation: Official Ubuntu Documentation
    * Management: Welcome! - Landscape
    * Support: https://ubuntu.com/advantage

    0 pakettia voidaan päivittäää.
    0 päivitystä on turvallisuuspäivityksiä.
    """"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
     
  12. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Eikö se sit oo tuo motd tiedosto?
     
    karhukopla tykkää tästä.
  13. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    /etc/pam.conf tuo?
     
    karhukopla tykkää tästä.
  14. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017
    Koitin käynnistää puttyn uudelleen. En pääse enään kirjautumaan, saan viestin:
    Putty Fatal Error, yhteys torjuttu.

    sudo service ssh reload
    ssh.service is not active, cannot reload.

    sudo /etc/init.d/ssh start
    [....] Starting ssh (via systemctl): ssh.serviceJob for ssh.service failed because the control process exited with error code. See "systemctl status ssh.service" and "journalctl -xe" for details.
    failed!
     
  15. nnaku

    nnaku I'm object-oriented! Premium-jäsen

    Viestejä:
    286
    Rekisteröitynyt:
    28.11.2016
    Itse asiassa tuli tyrittyä tuon edellisen viestin kanssa... (copypate munaus) Toi session rivi ei kuulu tonne sshd_confiin vaan samaan tiedostoon mistä piilotat ton motd.dynamicin.

    Luultavasti tuo /etc/run/motd.dynamic tiedosto muuttuu kun softa päivittyy joten... mod.tail laitat mitä haluta ja käyt kommentoimassa ton mod.dynamicin pois tiedostosta
    Koodi:
    sudo nano /etc/pam.d/sshd
    tälle riville #
    #session optional pam_motd.so motd=/run/motd.dynamic
     
    karhukopla tykkää tästä.
  16. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017

    Mä en ymmärrä. En pääse kirjautumaan enään puttyyn tai käynnistämään putty servua.
    Minkä session rivi ei kuulu minne? Olisiko kuvaa laittaa?
     
  17. nnaku

    nnaku I'm object-oriented! Premium-jäsen

    Viestejä:
    286
    Rekisteröitynyt:
    28.11.2016

    kerkisit sitte napata tossa välissä ton rivin minkä muokkasin...

    Koodi:
    session    optional   pam_motd.so  motd=/etc/motd.tail
    ei kuulu tänne...
    Koodi:
     /etc/ssh/sshd_config
    vaan se kuuluu tänne
    Koodi:
     /etc/pam.d/sshd
     
    karhukopla tykkää tästä.
  18. karhukopla

    karhukopla

    Viestejä:
    48
    Rekisteröitynyt:
    19.03.2017
    Jippii, sain sen toimimaan. :)
     
    tatulpin, nnaku ja copter tykkäävät tästä.
  19. zepi

    zepi

    Viestejä:
    784
    Rekisteröitynyt:
    17.10.2016
    Löytyisikö täältä alsa-guruja optimoimaan raspberry pi - alsa resamplauksia? Olen yrittänyt käyttää volumio-distroa tuon kanssa ja hommat mielestäni toimivat muuten, mutta en ole saanut yleispätevää alsa-resamplausta konffattua joka imuroisi "kaiken" itsensä läpi.

    Ongelmat aiheuttaa raspin perässä oleva USB-DAC, joka ei tue mitään muuta kuin 96KHz näyteistystä (tai näin ainakin linuxissa). Tarvitsisin siedettävän hyvälaatuisen resamplauksen kaikelle äänelle niin, että ilman erillistä säätöä defaulttina äänet menevät jonkun alsa-virtuaalidevicen läpi, joka resamplaa väkisin 96KHz outputille.

    Olisiko jollain heittää suoraan konffit miten moinen toteutetaan?
     
  20. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 031
    Rekisteröitynyt:
    19.10.2016
    Koodi:
    defaults.pcm.rate_converter "samplerate_best"
    
    pcm.!default {
      type plug
      slave.pcm {
        type dmix
        ipc_key 1024
        slave {
           pcm "hw:0,0"
           rate 96000
        }
      }
    }
    Jotain tuon tapaista /etc/asound.conf tiedostoon. Jos on useita äänilaitteita, niin "hw:0,0" oikeat numerot saa "aplay -l" komennolla, eka on kortti ja toinen laite. Jos *_best vie liikaa resursseja, niin testaa "samplerate_medium".

    alsa.opensrc.org

    Jos ei toimi, niin voi yrittää soveltaa vaikka tuosta M-Audion konffista.
     
  21. Monologi

    Monologi

    Viestejä:
    900
    Rekisteröitynyt:
    17.10.2016
    Orange Pi Zerossa on DietPi linux käyttis ja näytti olleen pois pelistä verkkoyhteyden osalta, että reitittimen hallinta softassa ei näkynyt koko vehjettä ja vanha ip oli puttyssä muistissa niin ei löytänyt masiinaa sitäkään kautta ennen buuttia.

    Sitä kysyn, että miten linuxista voi katsoa, että mikä kaatumisen aiheutti?

    Olisi myös siisti sellainen ohjelma, joka osaisi myös pitää logia kuinka pitkään se on ollut verkossa.

    edit: reitittimestä itsestään löytyi logi. 20.3.2017-12.4.2017 on dietpi:n ip:ssä liikkunut dataa ja sen jälkeen ei ollenkaan eli tuolloin varmaan pudonnut verkosta.
     
    Viimeksi muokattu: 19.04.2017
  22. telcoM

    telcoM

    Viestejä:
    55
    Rekisteröitynyt:
    18.03.2017
    /var/log hakemistosta löytyy lokitiedostoja joista kannattaa aloittaa, ja /var/log/messages siellä paras arvaus jos käytettävän jakelun logituskäytäntö ei ole ennestään tiedossa.

    RedHat-sukuisissa jakeluissa on yleensä päälogit /var/log/messages ja /var/log/secure: securessa on kirjautumistapahtumiin liittyvät viestit ja muut sellaiset joissa logiviestiin voi periaatteessa päätyä salasanoja jos käyttäjä kirjoittaa salasanan käyttäjätunnuksen paikalle vahingossa.

    Debian-sukuisissa logien nimet ovat osittain vähän erilaiset ja niitä on oletuksena enemmän: /var/log/messages on suunnilleen sama kuin RedHatissa, mutta securen tilalla on auth.log. Lisänä voi olla sitten syslog, daemon.log, kern.log ja user.log.

    Yllämainituissa logeissa on yleensä oletusasetuksilla automaattisiivous päällä siten, että logit siivotaan viikottain ja tallessa on kertyvä ja noin 4 vanhaa versiota.

    Ajastettujen operaatioiden toteutumisesta kertoo /var/log/cron, sähköpostin lähetyksestä ja vastaanotosta /var/log/mail tai /var/log/maillog.

    Jos koneessa on systemd käytössä, komenna "journalctl --list-boots" ja näet kuinka monen boottikerran logit ovat tallella. Jos se tulostaa vain yhden rivin (= tallessa on vain nykyisen boottikerran journal-logi) kannattaa varmistaa että /var/log/journal hakemisto on olemassa, koska jotkut jakelut eivät luo sitä oletuksena.
    Jos se oli olemassa kun kone käynnistettiin, sitten komennolla "journalctl -x -b -1" näyttää sivutettuna edellisen boottikerran journal-logit (joista siis löytyy mitä kaikkea systemd milloinkin käynnisti/pysäytti ja miten siinä kävi), "journalctl -x -b -2" sitä edellisen, ja niin edespäin.

    Jos kdump-ominaisuus oli asetettu käyttöön ja levytilaa riitti, sitten /var/crash-hakemistossa saattaa olla odottamassa muistivedos, josta voi sitten saada hyvinkin tarkkaa tietoa siitä mitä kone oli tekemässä kun kaatuminen tapahtui.
     
  23. Monologi

    Monologi

    Viestejä:
    900
    Rekisteröitynyt:
    17.10.2016
    apache2 boottime dietpi-software_apt.log news samba
    apt btmp dpkg.log ntpd.log wtmp
    armhwinfo.log dietpi-boot.log fsck ntpstats

    Nuo sieltä log kansiosta löytyi ja kaikki log-päätteiset on tyhjää täynnä.
    Sitten muistinkin, että DietPi on jonkin verran kutistettu versio--> DietPi vs Raspbian Lite

    ram logit menee rammiin eli nehän katoaa kuin pieru saharaan bootissa. Ei ole crash-kansiota

    DietPi / Fuzon • View topic - DietPi-Software | Details for ALL installation options

    "DietPi-Ramlog #1 (default):
    Ideal for users who do not require log files.
    + Mounts /var/log to RAM.
    + Increases overall system performance.
    + Increases the life of your SDcard by reducing filesystem IO (read/writes).
    + DietPi will automatically clear log files in /var/log every hour (to free memory used by DietPi-Ramlog).
    ─ Log files are NOT saved to disk.
    ─ Rsyslog is not installed to save on resources. This may prevent some programs logging that rely on rsyslog. If required, it can be manually installed with apt-get install rsyslog

    DietPi-Ramlog #2:
    Ideal for users who require the ability to keep log files, with the benefit of improved performance.
    + Mounts /var/log to RAM.
    + Increases overall system performance.
    + Increases the life of your SDcard by reducing filesystem IO (read/writes).
    + DietPi will automatically save/update log file data to disk every hour /root/logfile_storage.
    + DietPi will then clear log files in /var/log (to free memory used by DietPi-Ramlog).
    ─ Potential of losing upto 1 hour of log file data if power is interrupted.
    ─ Rsyslog is not installed to save on resources. This may prevent some programs logging that rely on rsyslog. If required, it can be manually installed with apt-get install rsyslog

    Full (Rsyslog & Logrotate):
    For users who require the maximum logging possible, with no interference from DietPi.
    ─ Mounts /var/log to DISK.
    ─ Decreases overall system performance
    ─ Reduces the life of your SDcard due to increased filesystem IO (read/write).
    + Comes with both rsyslog and logrotate installed as standard.
    + The "standard" of Linux logging systems, essential if your log file data is critical to system operation and/or maintenance. "

    Pitääkin laittaa tuo alin vaihtoehto, että jää jotain microsd:lle luettavaksi seuraavalla kerralla.

    Nyt löytyy enemmän log-kansiosta:

    alternatives.log btmp faillog ntpd.log
    apache2 daemon.log fsck ntpstats
    apt debug kern.log samba
    armhwinfo.log dietpi-boot.log lastlog syslog
    auth.log dietpi-software_apt.log log2ram.log sysstat
    bootstrap.log dmesg messages unattended-upgrades
    boottime dpkg.log news wtmp

    Esim. Journal ja kdump ei taida tässä olla ollenkaan, mutta toivottavasti noilla full moodin logeilla irtoaa sitten tarpeeksi tietoja ja vilkaisin noita kaikkia valmiiksi niin niissä on sisältöä suurimmaksi osaksi.
    Omaan silmään kdumpin asentaminen itse jälkikäteen näyttää aika pahalta rastilta.
     
    Viimeksi muokattu: 19.04.2017
  24. Lexy

    Lexy Team R&T

    Viestejä:
    119
    Rekisteröitynyt:
    17.10.2016
    Tämä menee varmaan sarujaan noobit kysymyset mutta:

    Minulla on Linux Mint (uusin versio asennettuna) HTPC:ssä. Näyttiksenä on 1050ti. Lisäksi on LG:n soundbar joka merkittävässä roolissa tässä ongemassa.

    Tuli vastaan tälläinen ongelma:
    1.
    Tietokone on kiinni telkkarissa (LG 4k) HDMI:llä. Tällöin saan Mintissä4k resoluution näkyviin jos kaapeli vedetään koneesta suoraan telkkariin. Äänet kulkisivat silloin optisella soundbariin mutta tällöin en saa kuin 2.0 äänet (soundbar on 4.1 eli erillinen basso löytyy myös). Nvidian asetuksista löytyy 4k moodit ja resoluutio ok, mutta äänet ei siis.


    2. Jos vedän HDMI:n soundbarin HDMI in-porttiin ja ja toisen HDMI out-portista telkkariin saan Linuxin puolella kaikki äänikanavat toimimaan mutta tällöin en saa 4k kuvaa / resoluutio. NVidian asetuksista löytyy vain 1080p moodi (ja sitä alemmat.) Äänikavat siis ok, mutta 4k resoluutiota ei löydy ja Nvidian Advanced asetuksista jos säädän 4k resolution niin se palautuu 1080p:ksi.

    Mitäköhän tässä pitäisi tehdä ja mitä kautta kannattaisi tuota nyt ratkaista?
     
  25. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Etkö saa äänikortin aseetuksista säädettyä optiselle monikanavatukea päälle? Siis Nvidiahan ei sitä optista ohjaa.
     
  26. Lexy

    Lexy Team R&T

    Viestejä:
    119
    Rekisteröitynyt:
    17.10.2016
    Täsmennetään vähän:
    Optistakaapelia käytettäessä kaapeli ei tule tietokoneesta vaan menee telkkarista suoraan tuolle soundbarille (paitsi yhdessä testiskenaariossa).

    Scenaariot siis
    1.1:
    Tietokone (HDMI) <-> TV <-> Optinen kaapeli <-> soundbar = 4k resoluutio mutta 2.0 äänet, ei ääntä monikanava testissä, eikä elokuvissa (front right ja left ok)

    1.2:
    Tietokone (HDMI) <-> TV ; Tietokoneen äänikortti <-> Optinen kaapeli <-> soundbar = 4k resoluutio mutta 2.0 äänet, ei ääntä monikanava testissä, eikä elokuvissa (front right ja left ok)

    2.0
    Tietokone (HDMI) <-> Soundbar HDMI IN - Soundbar HDMI Out (HDMI) <-> TV = Monikanava äänet toimii HDMI:n kautta mutta resoluutio pakotettu 1080p, manuaalisesti NVidian asetuksista (Advanced settings) saat ns. työpöytä 4k mutta leffat ja natiivit ohjelmat ilmoittaa että resoluutio on oikeasti 1080p.

    ja disclaimer: Windowsin puolela kaikissa skenaarioissa siis 4k kuva ja monikanava.
     
  27. neoflix

    neoflix

    Viestejä:
    483
    Rekisteröitynyt:
    19.10.2016
  28. Lexy

    Lexy Team R&T

    Viestejä:
    119
    Rekisteröitynyt:
    17.10.2016
    Tuotakin taisin jo katsoa mutta tuo skenaario ei ole ihan vastaava. HDMI:llä (jättäen kokonaan pois optisen, skenaario 2.0) siis monikanava toimii mutta 4k (kyseinen resoluutio ei ede valittavissa). 1.2 skenaariossa tuo olisi tilanne mutta se on ei toivotuin vaihtoehto koska kaapelin vaihto. Paras olisi kun saisi 1.1 skenaarion toimimaan koska se on jo todettu muussa ympäristössä toimivaksi (Windows + Kodi).

    Täytyy katsoa tuo ALSA vielä uudelleen.
     
  29. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 031
    Rekisteröitynyt:
    19.10.2016
    Tukeeko soundbar 4k-läpivientiä?

    Oma Anthem vahvistin ei tue 4k@60Hz läpivientiä, niin toinen HDMI on kytketty suoraan telkkuun ja toinen HDMI vahvistimeen, Kodi osaa syöttää äänet ja kuvan eri lähtöihin.
     
  30. Lexy

    Lexy Team R&T

    Viestejä:
    119
    Rekisteröitynyt:
    17.10.2016
    Tukee,varmistin vielä äsken;kuten todettu Windowsin puolella toimii suoraan kaikki esitetyt skenaariot.
     
  31. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 031
    Rekisteröitynyt:
    19.10.2016
    Tässä ei kai kuulukaan toimia monikanava-testi, mutta DTS ja DD passthrough pitäisi toimia.

    /var/log/Xorg.0.log tms. tiedostosta voi tutkailla virheitä (EE) eri tapauksissa ja Googlata niiden perusteella.
     
  32. Lexy

    Lexy Team R&T

    Viestejä:
    119
    Rekisteröitynyt:
    17.10.2016
    Hmm,outoa jos tuossa ei kuulu monikanava testi kun toisessa (pelkkä hdmi passthrough) toimii.DTS jne. testattu Kodin ja VLC:n kautta ja ei eloa (=osa kanavista ei kuulu,esim. puhe).

    Kagson tuon läpi ja postailen tänne kun pääsen kotia.
     
  33. Pertti Kosunen

    Pertti Kosunen Basic Input/Output System

    Viestejä:
    1 031
    Rekisteröitynyt:
    19.10.2016
    Optisen ja HDMI ARC läpi ei mene kuin stereo, DTS/DD kuljetetaan kahden PCM-kanavan läpi (ne voi koodata jopa stereo wave tiedostoon, jos ajurit/ohjelmat ei tue läpivientiä). Kodi/VLC ei saa purkaa ääntä jolloin tulee vain stereo vaan pitää kytkeä passthrough käyttöön.

    Uudessa Kodissa täytynee jättää sync playback to display pois päältä, että passthrough äänet toimii. Näyttötilan virkistystaajuuden vaihto pitää tietinkin olla (varsinkin) tuossa tapauksessa päällä, että nykii mahdollisimman vähän.
     
  34. Monologi

    Monologi

    Viestejä:
    900
    Rekisteröitynyt:
    17.10.2016
    Luulin, että OrangePi Zero oli mennyt nurin, kun ei näkynyt reitittimellä ja logissa oli dataa liikkunut nolla tänään. Kuitenkin, kun putty:llä sorkin niin pääsin sisään. Toki olin päivittänyt uudempaan versioon tuon DietPi.
    Näköjään ei ollut ihan aukoton tuo reitittimellä läsnäolo ja data nolla, että tuossa on varmaan jonkinlaisia virransäästöominaisuuksia käyttämättömänä ja haiskahtaa turvalliseltakin, kun ei data liiku. Mihin se sitä olisi edes viemässä?
     
  35. telcoM

    telcoM

    Viestejä:
    55
    Rekisteröitynyt:
    18.03.2017
    Näinhän se on. Tavalliset windows-koneet usein huutelevat silloin tällöin broadcastia lähiverkkoon ilmoittaakseen olemassaolostaan toisille saman verkon windows-koneille (elleivät ole AD-domainissa kiinni, jolloin huutelu tapahtuu kohdistetusti AD-palvelimille), tarkistavat Microsoftilta päivityksiä ym., ja siitä tulee sivutuotteena jonkin verran tavaraa liikennelaskureihin. Mutta tuollainen DietPi josta on kaikki ylimääräinen riisuttu pois ei välttämättä huutele ulospäin yhtään mitään idlenä ollessaan.
     
  36. kaakau<"'\\/>

    kaakau<"'\\/>

    Viestejä:
    62
    Rekisteröitynyt:
    02.11.2016
    Nyt kun päivitin Kubuntun 17.04:n, niin alkoi taas sellainen ongelma, kun joskus ikkunan aukaistessa se jää mustaksi tai on jotain muuta häiriötä, ei renderöidy kunnolla. Vaikka Firefoxia käyttäessä painaa oikeaa hiirennappia ja se context menu -ikkuna onkin musta. Sama ongelma oli aiemmin, mutta se taisi silloin liittyä enemmänkin suspendista palautumiseen, koska kun aloin vain aina sammuttamaan koneen yöksi ei ko. häiriötä enää esiintynyt. Silloin huomasin, että uudelleenkäynnistämällä compositorin ongelma hävisi hetkellisesti ja kokeilin pelailla rendering backend- ja tearing prevention -asetuksilla. Nyt asettamalla rendering backend käyttämään XRenderiä ongelmaa ei taida esiintyä, mutta tällä asetuksella esim. videoita katsoessa välillä keskellä näyttöä kuva ei päivity kunnolla, näkyy näytön levyinen matala jokin häiriö.

    Mistä voisi johtua ja mitä tehdä?

    Näytönohjain on Intel HD 4600.

    Kokeilen hetken oletusasetuksilla vielä.
     
  37. Monologi

    Monologi

    Viestejä:
    900
    Rekisteröitynyt:
    17.10.2016
    Tuo oli yhdessä vaiheessa kaatunut vastaavasti ja kun kolusin läpi logeja niin ei sieltä mitään tolkullista löytynyt ja se ei ollut tehnyt sellaista päivämäärä kohtaista logia, vaikka full log päällä. Windows tekee sen pyytämättä.
    Pieni epäilys, että pitää aina kirjautua Puttyllä sisään tuohon laitteeseeen, että ei jätä sitä kyselyä sinne haisemaan. Voi kait sen takia kaaduta esim. ssh ohjelma.
     
  38. Falconi

    Falconi

    Viestejä:
    32
    Rekisteröitynyt:
    11.05.2017
    Onko CentOS lähellä Red Hat Enterprice 5 - 7? tai SUSE Enterprice 11?

    Autodeskin lisenssimanageri toimii vain yllämainituissa (+ OSX ja WIN), mutta esim. digital oceanilla ym VPS toimittajilla on vain halpoja Ubuntuja tai CentOS:ja tai sitten jotain muita.
     
  39. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Centos on käytännössä sama kuin redhat samalla numerolla. Redhat on maksullinen ja sisältää yritystason tukea ja centos taas ilmainen ja "googletuen" piirissä.
     
    Falconi ja aohman tykkäävät tästä.
  40. dragon age

    dragon age

    Viestejä:
    140
    Rekisteröitynyt:
    18.10.2016
    Asensin Linux Mintin, Steam ei käynnistynyt, tuli error radeonsi dri so, asensin sitten amd ajurin, sitten black screen.
    Seuraavaksi yritin asentaa Linuxin uudestaan mutta grub installer kaatui aina?
     
  41. Bl-Papu

    Bl-Papu

    Viestejä:
    10
    Rekisteröitynyt:
    20.10.2016
    Koita vaihtaa Linuxin asennustikku legacy modeen Biosissa. Tämä jos sulla on toisella levyllä Windows ilman UEFIa.
     
  42. dragon age

    dragon age

    Viestejä:
    140
    Rekisteröitynyt:
    18.10.2016
    No näinhän se varmasti onkin, mistä tiedät tämän? Yritin googlettaakkin juuri tätä erroria:
    "libGL error: unable to load driver: radeonsi_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: radeonsi
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast"

    Ja aina vain löytyi jotain seuraavanlaisia ratkaisuehdotuksia:

    [SOLVED] Steam doesn't start with AMD Free drivers :: Steam for Linux General Discussions
     
  43. Bl-Papu

    Bl-Papu

    Viestejä:
    10
    Rekisteröitynyt:
    20.10.2016
  44. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Mint on ubuntu samoin kuin redhat on centos
     
  45. greenlight

    greenlight

    Viestejä:
    289
    Rekisteröitynyt:
    17.10.2016
    edit: huoh
     
  46. Baldrick

    Baldrick

    Viestejä:
    270
    Rekisteröitynyt:
    24.10.2016
    Ja Ubuntu on debian.
     
  47. Monologi

    Monologi

    Viestejä:
    900
    Rekisteröitynyt:
    17.10.2016
    Armbiania tullut käytettyä, mutta jäänyt kuva, että Debian ja Ubuntu on hyvin tuottejuja käyttiksiä foorumipiireissä. Ihan pintapuolinen ahaa elämys.
    Centos ei sano mitään eli heikko tuki.
     
  48. TheMeII

    TheMeII echo "%0|%0">s.bat|s Tukijäsen

    Viestejä:
    947
    Rekisteröitynyt:
    13.11.2016
    Centos on isossa roolissa palvelimilla.
     
  49. Stephen Elop

    Stephen Elop

    Viestejä:
    125
    Rekisteröitynyt:
    07.03.2017
    Tollasella haulla löytyy vastaus "steam libGL error: unable to load driver: radeonsi_dri.so" tuohon alkuperäiseen ongelmaan.

    Kyseessä on siis se että steam sisältää eri versiot noista ajureista/kirjastoista, mitä itse käyttis käyttää. Ongelmien pitäisi poistua, kun poistaa kyseiset ajurit käyttäjän steam asennuksesta.
     
  50. dragon age

    dragon age

    Viestejä:
    140
    Rekisteröitynyt:
    18.10.2016
    Miten Linux toimii jos asentaa lga771 Xeonin lga775 emolevylle?