Kummallinen ongelma Zyxel DX3301-T0:n kanssa

Liittynyt
10.12.2016
Viestejä
175
Vähän long shot, mutta jos jollakulla sattuisi olemaan vinkkejä.

Eli, tavallinen pöytä-PC ja Zyxel DX3301-T0 VDSL-modeemi. Käyttis Ubuntu 23.04. Modeemi ja PC ethernet-kaapililla kiinni toisissaan.

Jos boottaan Ubuntun, kun Zyxel on jo valmiiksi päällä, netti ei ala kunnolla toimimaan. Kone saa IP-osoitteen DHCP:lla, mutta esim. suora ping modeemiin näyttää tältä:

Koodi:
PC:~/>ping 192.168.1.1

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.100 icmp_seq=1 Destination Host Unreachable
Reititystaulu ($ route -n) näyttää ihan normaalilta kyseisessä tilanteessa.

Myöskään
Koodi:
$ sudo systemctl restart networking
ei ratkaise tilannetta, eikä myöskään netti-interfacen alas/ylösvienti ohjelmallisesti UI-työkaluilla.

Verkkokaapelin fyysinen irroitus modeemin ja pc:n välillä sekunniksi ratkaisee tilanteen välittömästi. Kaikki alkaa heti toimia.

Samaten jos käynnistän Zyxelin kun PC on jo bootannut Ubuntuun, niin kaikki toimii normaalisti heti kun modeemi on saanut wan-asiat kuntoon.

Windowsilla ei samalla rautakokoonpanolla esiinny mitään ongelmia.
Ubuntulla ei esiintynyt vanhan modeemin (Telewell TW-EAV510) mitään ongelmia.
 
Liittynyt
27.12.2018
Viestejä
2 382
Mitä sanoo: $ sudo ethtool <if-nimi>
silloin kun vika on päällä vs silloin kun ok? Ellei ole asennettu, niin:
$ sudo apt install ethtool
 
Liittynyt
10.12.2016
Viestejä
175
Mitä sanoo: $ sudo ethtool <if-nimi>
Ethtoolin ulostulo on identtinen, oli vikaa tai ei:

Koodi:
Settings for enp0s31f6:
        Supported ports: [ TP ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric Receive-only
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: Symmetric Receive-only
        Link partner advertised auto-negotiation: Yes
        Link partner advertised FEC modes: Not reported
        Speed: 1000Mb/s
        Duplex: Full
        Auto-negotiation: on
        Port: Twisted Pair
        PHYAD: 1
        Transceiver: internal
        MDI-X: on (auto)
        Supports Wake-on: pumbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes
Samoin ifconfig ja route -n antavat identtiset vastaukset riippumatta siitä, onko vika päällä vai ei.
 
Liittynyt
27.12.2018
Viestejä
2 382
En tiedä olisiko sama ongelma Zyxel DX3300-T0:n kanssa, joka on ilmeisesti samalla firmiksellä toimiva rautavariaatio samasta (operaattori)rimpulasta.
Käyttötapauksena tässä tapauksessa herättää Windows-laptop hibernaatiosta sisäisellä Intel-ethernetillä piuha kiinni. Joko purkki ei vastaa pingiin tai toimii muuten, mutta DHCP-servu on kuollut. Mielestäni alkuperäinen firmis oli V5.50(ABVY.2)C0, mutta nyt se on päivittynyt omia aikojaan uusimpaan V5.50(ABVY.4)C0. Alun perin ivo-bootteja tarvittiin muutaman viikon välein, nyt lähes päivittäin.

Kun nyt tuli kaivettua tämä säie esiin, niin pitää kokeilla seuraavassa jumissa (luultavasti huomenna) piuha irrottaen ja vaikka jollain muulla asiakaslaitteella. Tölkki on vain ethernet-reitittimenä eli esim. VDSL2-puoli ei ole käytössä.
 
Liittynyt
27.12.2018
Viestejä
2 382
Kun nyt tuli kaivettua tämä säie esiin, niin pitää kokeilla seuraavassa jumissa (luultavasti huomenna) piuha irrottaen
Kävi kuten ennustin, eli kun client nousi horroksesta ja oli mielestään 1 GbE:ssä kiinni, yhtään pakettia ei kulkenut kumpaankaan suuntaan. Piuha irrottaen reitittimen päästä tilanne korjaantui heti.

Eli vaikuttaa samalta ilmiöltä OP:n kanssa
 
Toggle Sidebar

Statistiikka

Viestiketjut
239 262
Viestejä
4 189 200
Jäsenet
70 716
Uusin jäsen
ileesu

Hinta.fi

Ylös Bottom