AMD julkaisi uudet Radeon Software 20.4.1 -ajurit näytönohjaimilleen ja APU-piireilleen

Kaotik

Banhammer
Ylläpidon jäsen
Liittynyt
14.10.2016
Viestejä
19 394


Kaotik kirjoitti uutisen/artikkelin:
AMD on julkaissut uudet ajurit näytönohjaimilleen ja APU-piireilleen. Radeon Software Adrenalin 2020 Edition 20.4.1 -ajurit ovat saatavilla Windows 7- ja 10 -käyttöjärjestelmille ja ne tukevat kaikkia yhtiön GCN- ja RDNA-arkkitehtuureihin perustuvia näytönohjaimia.

Radeon Software 20.4.1 -ajureiden merkittävin uudistus on virallinen tuki Resident Evil 3:lle, Resident Evil 3: Nemesiksen tuoreelle remake-versiolle. Julkaisutiedotteessa ei ole mainintaa mahdollisista suorituskykyeroista aiempiin ajureihin nähden.

Tuttuun tapaan ajureissa on korjattu aiempien ajureiden ongelmia. Liiskattujen bugien listalle ovat päässeet tällä kertaa HDR:n tunnistuksen ja päälle laiton ongelmat Vulkan-rajapinnalla sekä Overwatch- ja Heroes of the Storm -peleissä joillain Vega-kokoonpanoilla esiintyneet kaatumiset mustaan ruutuun. Tiedossa olevia ongelmia ovat puolestaan esimerkiksi Folding@Home -sovelluksen ja rautakiihdytystä käyttävän videotoiston mahdollisesti aiheuttama mustaan ruutuun kaatuminen, RX Vega -sarjalla esiintyvät kaatuilut kun Instant Replay -ominaisuus on käytössä ja tehtävänvaihdossa (Alt+Tab) sekä mahdollinen nykiminen joissain peleissä RX 5000 -sarjan näytönohjaimilla. Voit tutustua ajureiden kaikkiin muutoksiin niiden julkaisutiedotteessa.

Lataa AMD:n ajurit täältä

Linkki alkuperäiseen juttuun
 
Liittynyt
22.10.2017
Viestejä
3 970
Mikähän ihme näissä ajureissa on. Kaikki toimi tähän päivään asti täysin ongelmitta. Testailin mikrofonin äänenvoimakkuutta ja yritin ReLivellä katsoa miten pelin äänet kuuluu puheen alta jne.
4-5 kertaa kaikki toimi kuten kuuluu, mutta sit relive alkoi tallentamaan tyhjiä 1kt kokoisia videotiedostoja. Enää ei tullut edes ruudulle ilmoitusta tallennuksesta.

No asensin 20.3.1 ajurit ja kaikki toimii kuten kuuluu, mutta uudet ajurit sisään ja taas tulee 1kt tiedostoja.
Ja kun tosiaan toimi jo ihan hyvin näillä uusilla, alkoi tuossa kun tein monta lyhyt videota, niin joku sekosi.

Mitähän tälle voi tehdä?
 

Kaotik

Banhammer
Ylläpidon jäsen
Liittynyt
14.10.2016
Viestejä
19 394
Mikähän ihme näissä ajureissa on. Kaikki toimi tähän päivään asti täysin ongelmitta. Testailin mikrofonin äänenvoimakkuutta ja yritin ReLivellä katsoa miten pelin äänet kuuluu puheen alta jne.
4-5 kertaa kaikki toimi kuten kuuluu, mutta sit relive alkoi tallentamaan tyhjiä 1kt kokoisia videotiedostoja. Enää ei tullut edes ruudulle ilmoitusta tallennuksesta.

No asensin 20.3.1 ajurit ja kaikki toimii kuten kuuluu, mutta uudet ajurit sisään ja taas tulee 1kt tiedostoja.
Ja kun tosiaan toimi jo ihan hyvin näillä uusilla, alkoi tuossa kun tein monta lyhyt videota, niin joku sekosi.

Mitähän tälle voi tehdä?
Veditkö clean installilla (factory reset taisi olla nimi) vai vaan päälle?
Miltä tallennusasetukset näyttää noilla 20.4.1-ajureilla? (löytyy General-asetusvälilehdeltä muistaakseni)
 
Liittynyt
22.10.2017
Viestejä
3 970
Veditkö clean installilla (factory reset taisi olla nimi) vai vaan päälle?
Miltä tallennusasetukset näyttää noilla 20.4.1-ajureilla? (löytyy General-asetusvälilehdeltä muistaakseni)
Vedin vaan päälle, asetukset on ihan samat kummallakin ajureilla. Ja tosiaan uusillakin tuo toimi jo monta päivää ihan hyvin ja tänäänkin, kunnes jotain tapahtui ja alkoi tulemaan tuota tyhjää tiedostoa.
Nyt kun painan tallennusta (ctrl+alt+R) niin ilmestyy suoraan se tiedosto. Eli ilmeisesti se tallennus epäonnistuu alkuunsa ja siksi ei myöskään ruudulle tule mitään ilmoitusta tästä.

Edit: jos vedän clean asennuksen, niin täytyykö kaikki asetukset säätää takaisin? Vai saako sen jotenkin niin, että vetäis vain itse ajurit uusiksi.
 

Kaotik

Banhammer
Ylläpidon jäsen
Liittynyt
14.10.2016
Viestejä
19 394
Edit: jos vedän clean asennuksen, niin täytyykö kaikki asetukset säätää takaisin? Vai saako sen jotenkin niin, että vetäis vain itse ajurit uusiksi.
Ainakin pitäisi mennä asetusten sen sileän tien käsittääkseni, mutta voit tallentaa asetukset Settings > Snap Settings import/export talteen ja ladata uusilla
 
Liittynyt
17.10.2016
Viestejä
1 368
Vedin vaan päälle, asetukset on ihan samat kummallakin ajureilla. Ja tosiaan uusillakin tuo toimi jo monta päivää ihan hyvin ja tänäänkin, kunnes jotain tapahtui ja alkoi tulemaan tuota tyhjää tiedostoa.
Nyt kun painan tallennusta (ctrl+alt+R) niin ilmestyy suoraan se tiedosto. Eli ilmeisesti se tallennus epäonnistuu alkuunsa ja siksi ei myöskään ruudulle tule mitään ilmoitusta tästä.

Edit: jos vedän clean asennuksen, niin täytyykö kaikki asetukset säätää takaisin? Vai saako sen jotenkin niin, että vetäis vain itse ajurit uusiksi.
Ainakin pitäisi mennä asetusten sen sileän tien käsittääkseni, mutta voit tallentaa asetukset Settings > Snap Settings import/export talteen ja ladata uusilla
Juuri näin. Toi Export/Import toimii vielä todella nätisti ja se ilmoittaa vielä montako muutosta asetettiin sekä montako muutosta jäi tekemättä yhteensopivuuksien takia. Itse kun käytän MPT:tä Radeon VII -pariskunnan kanssa, niin tuolla asetusten export/import-kikalla ne saa nopeasti takaisin ja kohdilleen kun on ajanut MPT:llä uudet tehorajat ajurien jälkeen sisään. Suosittelen tutustumaan toimintoon, helpottaa todella paljon.

E: identtisten systeemien väliltä voi periaatteessa siirrellä asetuksiakin koneelta toiselle noin.
 
Liittynyt
22.10.2017
Viestejä
3 970
Laitoin DDU:lla kokonaan puhtaaksi ja asensin uudet ajurit, mutta relive tekee suoraan noita 1kt videoita. Eli ei toimi ollenkaan.

Mut siihen voi suoraan päälle ilman puhdistuksia heittää 20.3.1:t ja toimii täysin normaalisti. En enää ymmärrä jos ei edes nollaus auta.
Ymmärtäisin jos ei toimis ollenkaan, mutta kun tosiaan ajureiden julkaisusta asti toimi eiliseen. Eilen vain se 4-5 kertaa putkeen tehtyä 30sek videota aiheutti tuon ja sen jälkeen ei enää toiminut..

Edit: nyt kaiken lisäksi AMD softa ilmoittaa, että nuo 20.3.1 on uusimmat saatavilla olevat ajurit. Aikaisemmin tarjosi kyllä uusia, vielä tuossa 10min sitten.
 

Kaotik

Banhammer
Ylläpidon jäsen
Liittynyt
14.10.2016
Viestejä
19 394
Laitoin DDU:lla kokonaan puhtaaksi ja asensin uudet ajurit, mutta relive tekee suoraan noita 1kt videoita. Eli ei toimi ollenkaan.

Mut siihen voi suoraan päälle ilman puhdistuksia heittää 20.3.1:t ja toimii täysin normaalisti. En enää ymmärrä jos ei edes nollaus auta.
Ymmärtäisin jos ei toimis ollenkaan, mutta kun tosiaan ajureiden julkaisusta asti toimi eiliseen. Eilen vain se 4-5 kertaa putkeen tehtyä 30sek videota aiheutti tuon ja sen jälkeen ei enää toiminut..

Edit: nyt kaiken lisäksi AMD softa ilmoittaa, että nuo 20.3.1 on uusimmat saatavilla olevat ajurit. Aikaisemmin tarjosi kyllä uusia, vielä tuossa 10min sitten.
Tarkista että sulla on siellä asetuksissa "Preferred software version" laitettu "Recommended+optional" eikä pelkkä "Recommended" mikä taitaa olla vakioasetus, voi selittää tuon raportoinnin uusimmista ajureista.

Paha sanoa mikä bitti siellä on mennyt vinoon, koska homma kuitenkin toimi ensin. Pistä nyt joka tapauksessa bugiraporttia asiasta AMD:lle.
 
Liittynyt
22.10.2017
Viestejä
3 970
Tarkista että sulla on siellä asetuksissa "Preferred software version" laitettu "Recommended+optional" eikä pelkkä "Recommended" mikä taitaa olla vakioasetus, voi selittää tuon raportoinnin uusimmista ajureista.

Paha sanoa mikä bitti siellä on mennyt vinoon, koska homma kuitenkin toimi ensin. Pistä nyt joka tapauksessa bugiraporttia asiasta AMD:lle.
Joo laitoinkin jo raporttia menemään. Tuo asetus on kyllä päällä.
 
Liittynyt
22.10.2017
Viestejä
3 970
Laitoin DDU:lla kokonaan puhtaaksi ja asensin uudet ajurit, mutta relive tekee suoraan noita 1kt videoita. Eli ei toimi ollenkaan.

Mut siihen voi suoraan päälle ilman puhdistuksia heittää 20.3.1:t ja toimii täysin normaalisti. En enää ymmärrä jos ei edes nollaus auta.
Ymmärtäisin jos ei toimis ollenkaan, mutta kun tosiaan ajureiden julkaisusta asti toimi eiliseen. Eilen vain se 4-5 kertaa putkeen tehtyä 30sek videota aiheutti tuon ja sen jälkeen ei enää toiminut..

Edit: nyt kaiken lisäksi AMD softa ilmoittaa, että nuo 20.3.1 on uusimmat saatavilla olevat ajurit. Aikaisemmin tarjosi kyllä uusia, vielä tuossa 10min sitten.
Nyt koitin uusia 20.4.2 ajureita ja sama ongelma pysyy. 2.3.1:t toimii. Ei vaan voi käsittää. Enkö siis pysty enää pitämään näyttistä ajantasalla ollenkaan?
 
Liittynyt
18.10.2016
Viestejä
2 373
Jaaha. Pikkuhiljaa vissii alkaisi olemaan lähes kaikki black screen ongelmat teilattu... jotain toki vielä löytyy.
 
Liittynyt
22.10.2017
Viestejä
3 970
Nyt koitin uusia 20.4.2 ajureita ja sama ongelma pysyy. 2.3.1:t toimii. Ei vaan voi käsittää. Enkö siis pysty enää pitämään näyttistä ajantasalla ollenkaan?
Nyt oon kyllä kaiken mahdollisen koittanut, paitsi Windowsin uudelleen asennusta.

Päivitin Windowsin 1903->1909, poistin ajurit ddu:lla ja asensin uusiksi.
Sen jälkeen myös vielä koitin antaa AMD:n itse poistaa kaiken ja palauttaa tehdasasetukset. Ilman mitään mun asetuksia...silti relive tallentaa välittömästi 1kt tiedoston.

Kaiken tän jälkeen asensin 20.3.1 suoraan päälle, koitin ensin tehdasasetuksilla, toimii, latasin omat asetukset ja kaikki toimii niinku pitää.
Hulluinta tässä edelleen on se, että 20.4.1 toimi pari päivää ongelmitta, kunnes heitti ongelman päälle, eikä tosiaan 20.4.2 muuta tilannetta. Ja ongelma lähti siitä, kun testasin mikkiä ja tein useita muutaman sekunnin tallennuksia. Eli joku siellä meni tilttiin.

Onko tuolla ReLivellä joku välimuisti jossain tms joka olisi nyt vaihtunut eripaikkaan ja siellä on joku bitti jumissa? Mistä tuon ReLiven osalta mahtais saada kaiken nollattua?
 
Liittynyt
22.10.2017
Viestejä
3 970
Katso, onko muilla ollut samaa ongelmaa:
Google:
relive empty file
Olen yrittänyt parhaani mukaan googletella ja en ole löytänyt oikein mitään fiksua. Jossain yksittäisessä mainittiin Windows game Bar, mutta se mulla on jo pois käytöstä.
Muutaman keskustelun aiheesta löydän jo muutaman vuoden takaa, mutta mitään vastauksia/ratkaisuja niissä ei ole.

AMD:lle olen raporttia pistänyt molemmista ajureista mutta eihän ne niihin vastaa. Enkä löytänyt mitään lomaketta/spostia suoraan AMD:lle mistä vois kysellä suoraan.
 
Liittynyt
22.10.2017
Viestejä
3 970
Relive ongelmat vihdoin ratkaistu..

uudet ajurit asensin, 20.5.1 ja samat ongelmat jatkuu, ei auta. Noh, mua alko tää suoraan sanottuna v**uttaa ja aloin googlaamaan. Löysin yhden tavan saada logi tiedosto ulos tuosta tallennuksesta, mutta sen mukaan ongelma oli xinput ohjaimessa...Poistin käytöstä..ei auta.

No sit jatkoin googlaamista ja lopulta löysin ratkaisun:
Task manager auki ja etsii sieltä seuraavat prosessit, oli vähän eri nimillä, mutta kun availee kaikkia amd alkuisia "avaa tiedostosijainnissa", niin sit löytyy.
  • atieclxx.exe
  • atiesrxx.exe
  • AUEPDU.exe
  • AUEPLauncher.exe
  • AUEPMaster.exe
  • AUEPUC.exe
  • RadeonSettings.exe
Ja kun nämä sieltä sit löytyy, painaa oikeaa hiirtä, ominaisuudet, yhteensopivuus, muuta kaikkien käyttäjien asetuksia, suorita ohjelma järjestelmänvalvojana.
Sit koneen buuttaus ja kun avaa radeon softwaren, tulee 3-4 eri ilmoitusta et sallitaanko, niihin kyllä. Tadaa, nyt toimii.

Ja siis on nämä samat kyselyt tehnyt silloin aikanaan ja hyvin toiminu ja toimii sillä 20.3.1:llä, mutta vasta tämä järjestelmänvalvojaksi asettaminen poisti ongelman. Nyt toimii kaikki kuten pitää.
 
Liittynyt
22.10.2017
Viestejä
3 970
Jahas, no se siitä ilosta. 20.4.1 toimi silloin päivän kaksi ongelmitta ennen ongelmien alkua. No nyt tänäänkin toimi useampaan kertaan hyvin ja nyt yks kaks 1kt tiedostoja taas puskee. Tarkistin niin jokainen exe on kyllä järjestelmänvalvojana. En enää ymmärrä. Selkeästi siellä joku cache tms. menee solmuun ja ei anna sen jälkeen enää tallentaa mitään.

Tämän lisäksi ”näkymä editori”, eli scene editor ei tallenna ollenkaan niitä asetuksia mitä laitan, vaan koneen käynnistyksen jälkeen on oletukset.

Ja nyt tämän järjestelmänvalvoja jutun myötä kone pyytää AMD softille aina lupaa kun koneen käynnistän. Jokaiselle erikseen..

Edit: ja näköjään 20.3.1 toimii edelleen ongelmitta. Miten voi olla mahdollista...

Edit: päivitin piruuttani emolevyn Biossin ja nyt lähti taas toimimaan...nyt miten pitkäksi aikaa? :D
 
Viimeksi muokattu:
Toggle Sidebar

Statistiikka

Viestiketjut
187 112
Viestejä
3 403 604
Jäsenet
60 928
Uusin jäsen
islam

Hinta.fi

Ylös Bottom