Windows 10 ei käynnisty, asematunnukset sekaisin

Diziet Sma

Tukijäsen
Liittynyt
19.10.2016
Viestejä
1 432
Kaikenlaista kummaa on tullut nähtyä, mutta nyt tuli vastaan jotain uutta. Windows 10 ei suostu enää käynnistymään, näkyville tulee BSOD:



Lupauksesta huolimatta uudelleenkäynnistys ei tässä tilassa onnistu, vaan se pitää tehdä itse reset-nappulalla. Sen jälkeen Windows yrittää käynnistyä, epäonnistuu, ilmoittaa yrittävänsä korjata ongelman, mutta epäonnistuu siinäkin. Tarjolle tulee Advanced Settings, josta pääsen kokeilemaan erilaisia virheenkorjauksia. Harmi vain, että mikään niistäkään ei toimi. Pääsen kuitenkin komentoriville ja voin käynnistää Diskpartin, joka vihjaa mahdollisesta viasta:



Asema C, jolla on MBR ja Windows, onkin muuttunut asemaksi I. Aiemmin piilotettuna ollut pieni tunnukseton järjestelmäosio on nyt asema C, eikä käynnistys tietenkään onnistu siltä. Muutkin asematunnukset ovat muuttuneet, mutta niillä ei sinänsä ole väliä. Kaikki tiedostot ovat osioissa tallella. Jos saisin korjattua I:n C:ksi ja Windowsin käyntiin, muiden tunnusten palauttamisessa ei pitäisi olla ongelmaa.

Mutta sinne asti en pääse, vaikka Diskpart antaa kyllä korjata asematunnukset entiselleen. Korjauksen jälkeen ei voi jatkaa mitenkään ilman pakollista uudelleenkäynnistystä, ja silloin tunnukset palautuvat jostain syystä taas vääriksi. Windows jumittaa jälleen samaan tilaan kuin ensimmäisessä kuvassa.

Pystyn kyllä asentamaan Windowsin USB-tikulta uudelleen ja (luultavasti) voin siinä yhteydessä korjata boottilevyn asematunnuksen I:stä C:ksi. Mutta helpompaa tietysti olisi, jos tunnukset saisi jollain kikkakolmosella ennalleen, jolloin käynnistys tapahtuisi entiseen tapaan oikealta asemalta eli C:ltä. Kaipaisin nyt viisaammilta hyviä neuvoja, miten sen voisin tehdä. Tai parempia neuvoja, jos vika onkin jossain muualla.

Edit: Kakkoskuvassa näkyvät osiot 1-3 ovat kaikki samalla Intelin SSD-levyllä. Vika tuskin on kuitenkaan vain tällä levyllä, sillä muutkin tunnukset ovat sekaisin. Lisäksi levy itsessään on kunnossa, koska pystyin kopioimaan tiedostoja asemasta I (jonka siis pitäisi olla C) ongelmitta talteen toiselle levylle.
 
Viimeksi muokattu:

Desgorr

Make ATK Great Again
Liittynyt
19.10.2016
Viestejä
6 050
Jos otit Recovery valikosta Command Promptin auki, niin silloin nuo tunnukset on mitä sattuu. Eli Recovery tila on nuo automaattisesti määrittänyt.
Itse asematunnukset määritellään Windowsin rekisterissä, eli noita ei ole itse levylle muuten tallennettu. Siksi tuo @Technarchy:n ehdottama osiointiohjelmakaan ei toimisi, ellei se osaa lukea Windowsin rekisteristä asematunnuksia ja muuttaa ne sinne.

Kyllä tässä nyt on joku muu ongelma kun asematunnukset.

Mitä luultavimmin tuossa asennuksessa on mennyt rekisteri solmuun. Kokeile palauttaa aiempi palautuspiste: Troubleshoot->Advanced options->System restore

Jos tämä ei toimi, niin katso command promptilla löytyykö rekisteristä backuppeja sijainnista: \Windows\System32\config\RegBack

Lopuksi jos muu ei auta niin kokeile ajaa Windowsin asennusmedialta korjausasennus.
 
Viimeksi muokattu:

Diziet Sma

Tukijäsen
Liittynyt
19.10.2016
Viestejä
1 432
Mitä luultavimmin tuossa asennuksessa on mennyt rekisteri solmuun. Kokeile palauttaa aiempi palautuspiste: Troubleshoot->Advanced options->System restore
Kokeilin jo. Kolme aiempaa palautuspistettä on valittavissa, mutta yhdenkään palautus ei onnistu.

Jos tämä ei toimi, niin katso command promptilla löytyykö rekisteristä backuppeja sijainnista: \Windows\System32\config\RegBack

Lopuksi jos muu ei auta niin kokeile ajaa Windowsin asennusmedialta korjausasennus.
Kiitoksia avusta. Olen kyllä jo henkisesti valmistautunut koko Windowsin uudelleenasennukseen, mutta kokeilen ensin neuvojasi.
 

halkoliiteri

BANNATTU
BANNED
Liittynyt
21.10.2016
Viestejä
401
Sfc /scannow ei taida toimia toimia komentoriviltä ko. tilanteessa? Antaako winukka muuten ajella "dirty flashin" eli asentaa vaan vanhan päälle ilman datan menetystä? Ei ole kympin aikana tullu kertaakaan tarvetta, niin jäi mietityttämään onko moinen nykyisin mahdollista vai meneekö automaattisesti aina c-aseman formatoinniksi.
 
Liittynyt
17.10.2016
Viestejä
604
Tuolla recovery modessa asematunnukset ovat harvoin (jos koskaan) samat kuin Windowsin puolella, se on ihan normaalia. Asia pitää tietysti huomioida, jos ja kun tekee toimenpiteitä komentoriviltä.

Kokeilisin tuote rekisterin palauttamista backupista ihan ekana.
 
Toggle Sidebar

Statistiikka

Viestiketjut
246 772
Viestejä
4 313 253
Jäsenet
71 908
Uusin jäsen
iija

Hinta.fi

Ylös Bottom