Linux kysymyksiä

Liittynyt
20.10.2016
Viestejä
2 122
Eipä tuo Windowsikaan tunnu trimmiä ajavan usein, ku taas katsoi tuolta "Optimize drives", niin näytti että viimeksi 27 päivää sitten. Itse kun sammutan koneen joka päivä kunnolla, ei nuo hibernate systeemit kiinnosta, ku kone nykyään SSD avustuksella käynnistyy kuitenkin hetkessä ja ainakin oman kokemuksen mukaan saanut useasti tapella hibernaten aiheuttamia ongelmia käyttöjärjestelmästä riippumatta.
 
Liittynyt
17.10.2016
Viestejä
1 547
ku kone nykyään SSD avustuksella käynnistyy kuitenkin hetkessä
Eihän siihen kauan mene joo nvme:llä mutta eri asia on taas se kun pitää availla kaikennäköisiä softia ja niissäkin voi olla joku tilanne kesken (EDIT: en tarkoita, että ilman tietojen tallennusta tekisin mitään sleep/hibernateja, vaan esim. joku muutoshistoria jota pääsee selaamaan edestakas jos tarvitsee), se ärsyttäisi joten käytän sleep/hibernatea. Hibernate on toiminut muutamaa kertaa lukuunottamatta ilman mitään ongelmia. Ihan ensimmäisten kertojen kohdalla tuli yksi kokonaan jäätyminen ja kerran taisi olla bluetoothin kanssa ongelma herätyksen jälkeen mutta nyt varmaan yli 50 hibernatea putkeen eikä mitään erikoista. Joka kerta kyllä välähtelee mustalla ruudulla "hardware changed, hibernate might not work"-tyylinen viesti, ja joku viesti jos wlan on päällä mutta hyvin silti näyttää pelaavan. Toivottavasti jatkossakin, dual bootinkin takia ettei tarvi pelisession takia laittaa kaikkea linuxin puolella kiinni.
 
Liittynyt
20.12.2016
Viestejä
122
Meinasi pää hajota kun säädin uuden lelun Asus mini pc pn50 (4800u) kanssa. Uusimman Kubuntun laitoin vanhan tutun Lubuntun sijasta. Vaikutti pelittävän kaikki instalointi vaiheessa, mutta heitti black screeniä jota vähän pelkäsin kun uudesta raudasta kyse.

Nopee googlaus ja vaikutti et pitäisi saada grubiin laitettu bootti asetuksiin nomodeset. Ongelma vaan oli se, että en tiennyt miten tonne grubiin pääsee joskus aikoinaan taistelin sen kanssa vanhalla serveri/htpc koneella joka sitten jäi kun sillä homma pelitti kuhan yritin saada sitä menua hyvin ja urheilun vuoksi näkyviin. 3-4h meni niin vihdoin sain ton menun näkyviin.

Googlen ohjeet et shift:llä tai esc:llä pitäis ilmestyä. No shift ei tehnyt mitään ja esc tuli laitoksen bios. Jostain sain päähän et kokeilempa kun biosista poistun ilman, että muutoksia teen ja hakkaan esciä jos toimisi.. Ja se sitten toimi :D Sain vihdoin syötettyä ton nomodesetin ja pääsin sisään. Uusi kernel 5.8.14 sisään ja homma vaikutti jotain bootin kummallisia random tekstei lukuunottamatta toimivan. Huomenna jos pääsee Dockerit ja muut säätämiset tekemään.
 
Liittynyt
17.10.2016
Viestejä
1 547
Törmäsin tällaiseen varoitukseen:
If you have any filesystems on USB devices mounted before software suspend, they won't be accessible after resume and you may lose data, as though you have unplugged the USB devices with mounted filesystems on them.
Onko tämä vielä paikkansa pitävä varoitus? Eli jos on ulkoinen USB-kovo kiinni ja syystä tai toisesta kone menee suspend/hibernate tilaan, tai akku loppuu, niin millä todennäköisyydellä sen ulkoisen levyn tiedostot forever hukassa sitten? Voisiko mintissä/linuxissa conffata jotenkin, että aina kun suspend/hibernate/poweroff tehdään niin ensin automaattisesti järjestelmä unmounttaisi kaikki USB-mountit?
 
Liittynyt
01.08.2017
Viestejä
1 812
Älkää päivittäkö linux kernel (ubuntu) 5.4.0-51 versioon (joka tuli tänään?), ainakin omassa tapauksessa kävi niin että NVIDIA kortti katosi kokonaan, eikä enää tunnista kuin IGPU UHD 620. Ei tullut muita päivityksiä tänään kuin nuo "linux kernel 5.4.0-51" jutut.

Ihmettelin aluksi miksi käynnistyi uudelleenkäynnistyksen jälkeen niin nopeasti, sitten katsoin miksi tekstit näyttää niin pieneltä, sitten katsoin NVIDIA x Server settings asetukset ihan huvikseen, kaikki tiedot kadonneet :o ainoastaan "prime profiles" sivu oli tallessa, kaikki tiedot NVIDIA kortista ja ominaisuuksista kadonneet.

Näköjään muitakin ongelmia muilla käyttäjillä kun päivitetty 5.4.0-48 -> 5.4.0-51
 
Viimeksi muokattu:
Liittynyt
17.10.2016
Viestejä
587
Älkää päivittäkö linux kernel (ubuntu) 5.4.0-51 versioon (joka tuli tänään?), ainakin omassa tapauksessa kävi niin että NVIDIA kortti katosi kokonaan, eikä enää tunnista kuin IGPU UHD 620. Ei tullut muita päivityksiä tänään kuin nuo "linux kernel 5.4.0-51" jutut.

Ihmettelin aluksi miksi käynnistyi uudelleenkäynnistyksen jälkeen niin nopeasti, sitten katsoin miksi tekstit näyttää niin pieneltä, sitten katsoin NVIDIA x Server settings asetukset ihan huvikseen, kaikki tiedot kadonneet :o ainoastaan "prime profiles" sivu oli tallessa, kaikki tiedot NVIDIA kortista ja ominaisuuksista kadonneet.

Näköjään muitakin ongelmia muilla käyttäjillä kun päivitetty 5.4.0-48 -> 5.4.0-51
Eilen illalla tupsahti itelle tuo -51 kernel ja onneksi näyttää toimivan GTX1080.
 
Liittynyt
01.08.2017
Viestejä
1 812
5.4.0.52 kernel tulossa pian ulos (Focal, ubuntuupdates), toivon parasta :) kuitenkin tälläisiä ongelmia ei ole usein ollut omassa koneessa, ehkä vain joku virhe joka korjattiin nopeasti?
 
Liittynyt
17.10.2016
Viestejä
1 547
Täällä linux mint 20 ja 5.4.0-51 kerneli asennettu ja bootattu, ei mitään ongelmia RTX2060:sen kanssa.
 
Liittynyt
01.08.2017
Viestejä
1 812
Sain vasta NVIDIAn pelittämään, kun asensin uudemman kernel version, ohjelmalla "Ubuntu Mainline Kernel Installer", nyt siis käytössä 5.4.0-71. Samalla poistin ison kasan vanhoja, mitkä veivät vain tilaa.

GP108M (MX150) on siis NVIDIA kortti kannettavassa.
 
Liittynyt
14.10.2017
Viestejä
204
Palaan tähän VPN/SMB-ongelmaan, jossa siis en saa Windows-levyjakoa toimimaan VPN:n ollessa päällä, koska smbclient antaa virheilmoituksen "NT_STATUS_IO_TIMEOUT".

Voi olla että pulse on konffattu tarkastamaan tiettyjä asioita koneesta ja sen mukaan saa yhteyksiä tai ei.
Yksi helppo testi on ottaa yhteys molemmilla käyttiksillä ja tallentaa reittitaulu. Ja lopuksi vertaa saako molemmilla samat reitit.
En ole ihan sataprosenttisen varma mitä reittitaulua Windows näyttää, mutta Linuxissa reitti näyttää sellaiselta kuin odotinkin ja todennäköisesti siis sama kuin Windowsissa.

Ehkä kannattaisi kokeilla ubuntussa pulsen omaa clienttia kun sellainenkin löytyy linuxille.
Voi hyvinkin olla että Pulse Secure-ohjelmalla avattavalle VPN:lle sallitaan työpaikan päässä eri asiat kuin OpenConnect-VPN:lle.
Tätä pitää kysyä työpaikan IT-ihmisiltä, ei julkiselta webbifoorumilta.
Sain asennettua Pulsen clientin, vaikka niiden deb-paketti on jonkun amatöörin tekemä ja asennus vaati joidenkin vanhojen pakettien asentamista Ubuntu archivesta tähän tyyliin. Ongelman suhteen mikään ei muuttunut, eli vaikka VPN-yhteys näyttää toimivan ainakin http:ta käytettäessä kuten ennenkin, niin smbclientin ongelma on yhä täysin sama. Mitenköhän siellä työpaikan päässä edes tiedetään, mitä clientiä käytän? Vai onko tuo Pulsen käyttämä protokolla joku "proprietary" joka on vain osittain implementoitu openconnectissa?

Työpaikan IT-ohjeissa lukee suunnilleen, että "virallista Linux-tukea ei ole emmekä vastaa lisäkysymyksiin, mutta jos haluat kokeilla, niin vaihtoehdot on Pulse Secure tai openconnect".

Taidan seuraavaksi kokeilla asentaa virtuaalikoneen tähän kotona olevaan läppäriin, ja tehdä siitä identtisen työpaikalla olevan virtuaalikoneen kanssa (jossa siis levyjako toimii kun VPN on avattu Windows-hostissa). Tämä saattaisi auttaa, jos ongelman syy on jossain smbclientin konfiguraatiotiedostossa.
 
Liittynyt
17.01.2018
Viestejä
990
Palaan tähän VPN/SMB-ongelmaan, jossa siis en saa Windows-levyjakoa toimimaan VPN:n ollessa päällä, koska smbclient antaa virheilmoituksen "NT_STATUS_IO_TIMEOUT".


En ole ihan sataprosenttisen varma mitä reittitaulua Windows näyttää, mutta Linuxissa reitti näyttää sellaiselta kuin odotinkin ja todennäköisesti siis sama kuin Windowsissa.



Sain asennettua Pulsen clientin, vaikka niiden deb-paketti on jonkun amatöörin tekemä ja asennus vaati joidenkin vanhojen pakettien asentamista Ubuntu archivesta tähän tyyliin. Ongelman suhteen mikään ei muuttunut, eli vaikka VPN-yhteys näyttää toimivan ainakin http:ta käytettäessä kuten ennenkin, niin smbclientin ongelma on yhä täysin sama. Mitenköhän siellä työpaikan päässä edes tiedetään, mitä clientiä käytän? Vai onko tuo Pulsen käyttämä protokolla joku "proprietary" joka on vain osittain implementoitu openconnectissa?

Työpaikan IT-ohjeissa lukee suunnilleen, että "virallista Linux-tukea ei ole emmekä vastaa lisäkysymyksiin, mutta jos haluat kokeilla, niin vaihtoehdot on Pulse Secure tai openconnect".

Taidan seuraavaksi kokeilla asentaa virtuaalikoneen tähän kotona olevaan läppäriin, ja tehdä siitä identtisen työpaikalla olevan virtuaalikoneen kanssa (jossa siis levyjako toimii kun VPN on avattu Windows-hostissa). Tämä saattaisi auttaa, jos ongelman syy on jossain smbclientin konfiguraatiotiedostossa.
Ainakin ne pulse- ympäristöt joihin itse olen törmännyt validoivat clientin annettujen sääntöjen perusteella (esim pitää kuulua tiettyyn domainiin/virustorjunta/tms) ja jos ei täytä sääntöjä niin ei pääse kaikkialle. Saattaa olla että firmassasi on jotain vastaavaa käytössä, silloin on mahdollista että vain windows client toimii kaikilta osin. Jos windows+pulse ja linux virtuaali toimivat oikein niin tämä voi olla mahdollinen syy. Validoijalle on nimikin, se on "host checker" ja tarkastettavat asiat hallinnoidaan tietysti vpn- serverin päässä.

Oletettavasti olet jo kaivanut googlesta vastauksia tuohon io timeout- ogelmaan, monissahan viitataan joko dns- ongelmaan tai smb protokollaversioon.
 

tonkar

Tukijäsen
Liittynyt
20.12.2016
Viestejä
887
Linux Developers Discussing Possible Kernel Driver For Intel CPU Undervolting
https://www.phoronix.com/scan.php?page=news_item&px=Linux-Intel-Undervolt-Kernel
mielenkiintoista luettavaa. Tuon taustalla on pyrkimykset estää kirjoittaminen CPU MSR:ään user spacesta
https://www.phoronix.com/scan.php?page=news_item&px=Linux-Filter-Tightening-MSRs

nyt pallo on kokonaan Intelin insinöörien (ja lakitoimiston) käsissä:
There is a need for documentation concerning the relevant MSR(s) and thus waiting on Intel engineers to find such documentation internally and see if/what can be publicly released. Hopefully Intel's large open-source team will be able to provide some fruits soon as there are many Linux laptop users especially who would enjoy a supported means of easily under-volting their hardware on Linux especially with more vendors beginning to offer pre-loaded Linux laptops.
 
Viimeksi muokattu:
Liittynyt
17.10.2016
Viestejä
1 547
Mitenkäs linuxin/mintin saisi tekemään hibernaten JA rebootin? Normaalistihan hibernate sammuttaa koneen. Tarkoitus olisi tehdä skripti työpöydälle jonka ajamalla:

1) Käsketään grubia valitsemaan windows "menuentry" seuraavassa bootissa poikkeuksellisesti mutta sen yhden bootin jälkeen olisi mint taas default boottina (jotain vanhoja ohjeita tähän löysin mutta en vain ole saanut toimimaan, lisäksi grub-valikko meni vähän jotenkin oudoksi kun linux mintin tilalle tuli ubuntu teksti vaikka en mitään sellaisia muutoksia mihinkään tehnyt.. bootti kyllä toimii tosin).

2) Käsketään mint tekemään hibernate JA reboot.

Tarkoitus siis automatisoida windowsiin hyppääminen. Löysin tuohon toiseen vaiheeseen sellaisen ohjelman kuin "rtcwake" joka ensitestien jälkeen näytti toimivan ok. Ongelmaksi tuli vain, että etukäteen pitäisi tietää kuinka kauan hibernaten teossa kestää ja se aikamääre pitäisi antaa ohjelmalle että se tietää milloin herätetään kone automaattisesti. Hibernaten kestohan on riippuvainen siitä kuinka paljon muistissa on tavaraa. Jos antaa sekunneissa lyhyemmän ajan milloin herätetään kuin mitä se hibernate toimenpide kestää, niin herätys ei toimi koska se aika meni jo ohi hibernatea tehdessä. Eli pettymykseksi tuota rtcwake:a ei pysty oikein käyttämään. Onko jotain toista tapaa tehdä hibernate+reboot?
 
Liittynyt
17.10.2016
Viestejä
617
En tiedä mitä Mint nykyään pitää sisällään, enkä ole hibernaten kanssa vaivautunut väkertämään mutta jotakin tämänkaltaista tekisin itse:
Koodi:
# efibootmgr -n 0000
# sed -i '/^HibernateMode=/c\HibernateMode=reboot' /etc/systemd/sleep.conf
# systemctl hibernate
Missä 0000 on Windows bootloaderin entryn numero.

Lisäksi joku väkerrys joka esim. bootin yhteydessä ajaa scriptin joka kurkkaa onko HibernateMode=reboot ja palauttaa sen takaisin siihen mikä se normaalisti onkaan. Tai poistaa koko rivin. Ja toki tuo nyt toimii sillä oletuksella että sleep.conf on olemassa ja siinä on jo HibernateMode=jotakin valmiiksi. Mutta luonnollisesti tämä nyt ei mikään suora ohje olekaan, lähinnä jonkinasteinen ajatustason konsepti.
 
Liittynyt
17.10.2016
Viestejä
1 547
jotakin tämänkaltaista tekisin itse
Tänään oli kiirusta ja kerkesin alustavasti vain testaamaan mutta tuolla efibootmgr:lla ja sleep.conf:illa homma toimii unelmasti, ohittaa turhan grubinkin (tosin mulla on vain 2 sekunnin viive laitettu siihen menuun)! Kiitoksia!! Pitää huomenna/vkloppuna katsella tarkemmat toimenpiteet koko hommalle. Löysin tällaisen vielä jossa onkin apu tuohon sleep.conf:in kanssa kikkailuun.

Lopuksi pitäisi vielä keksiä miten voin tehdä skriptin työpöydälle jonka ajamiseen ei tarvita sudoa. Eli jos skripti "~/desktop/Winkkariin.sh" on about tällainen:
Koodi:
#!/bin/bash

sudo /path/to/enable-hibernate-reboot
sudo efibootmgr --bootnext 0004
sudo systemctl hibernate
Miten voin ilman mitään salasanoja käynnistää tuon skriptin? "/etc/sudoers":ia editoimalla? Voiko sinne lisätä vain tuon skriptitiedoston, vai pitääkö lisätä nuo kaikki (/path/to/enable-hibernate-reboot, efibootmgr, systemctl) sellaisiksi että ei kysytä sudoa ollenkaan? Jos vain jotenkin mahdollista niin mieluummin saisi vain tuon "Winkkariin.sh" ilman sudoa käynnistettäväksi.

EDIT: Ilmeisesti tuon saa ainakin tehtyä niin, että tekee vielä toisen skriptin ja kutsuu siinä "sudo Winkkariin.sh" joka siis on sudoers:issa laitettu sallituksi. Ei niin tyylikäs ratkaisu mutta jos toimii..
 
Viimeksi muokattu:
Liittynyt
17.01.2018
Viestejä
990
Tänään oli kiirusta ja kerkesin alustavasti vain testaamaan mutta tuolla efibootmgr:lla ja sleep.conf:illa homma toimii unelmasti, ohittaa turhan grubinkin (tosin mulla on vain 2 sekunnin viive laitettu siihen menuun)! Kiitoksia!! Pitää huomenna/vkloppuna katsella tarkemmat toimenpiteet koko hommalle. Löysin tällaisen vielä jossa onkin apu tuohon sleep.conf:in kanssa kikkailuun.

Lopuksi pitäisi vielä keksiä miten voin tehdä skriptin työpöydälle jonka ajamiseen ei tarvita sudoa. Eli jos skripti "~/desktop/Winkkariin.sh" on about tällainen:
Koodi:
#!/bin/bash

sudo /path/to/enable-hibernate-reboot
sudo efibootmgr --bootnext 0004
sudo systemctl hibernate
Miten voin ilman mitään salasanoja käynnistää tuon skriptin? "/etc/sudoers":ia editoimalla? Voiko sinne lisätä vain tuon skriptitiedoston, vai pitääkö lisätä nuo kaikki (/path/to/enable-hibernate-reboot, efibootmgr, systemctl) sellaisiksi että ei kysytä sudoa ollenkaan? Jos vain jotenkin mahdollista niin mieluummin saisi vain tuon "Winkkariin.sh" ilman sudoa käynnistettäväksi.

EDIT: Ilmeisesti tuon saa ainakin tehtyä niin, että tekee vielä toisen skriptin ja kutsuu siinä "sudo Winkkariin.sh" joka siis on sudoers:issa laitettu sallituksi. Ei niin tyylikäs ratkaisu mutta jos toimii..
Käytännön vaihtoehdot taitavat olla
1. kaikki skriptissä käytetyt komennot listattuna sudoers ja käyttö "./sckripti.sh"
2. skripti itse sudoers, komennot sen sisällä ilman sudoa ja käyttö "sudo ./skripti.sh"
 
Liittynyt
17.10.2016
Viestejä
1 547
En saa sudoers hommaa toimimaan. :( Visudo:lla lisäsin tällaisen rivin:

fubar ALL=(ALL:ALL) NOPASSWD: /home/fubar/.bin/hibernate_and_reboot_to_windows.bash

Ja sitten on desktop-kansiossa ajettava tiedosto jossa:
Koodi:
#!/bin/bash
sudo /home/fubar/.bin/hibernate_and_reboot_to_windows.bash
Mutta tuon ajaminen kysyy salasanaa.

Lisäksi aiempaan linkkiin viitaten, en saa tätä osaa toimimaan:

And also, a disable-hibernate-reboot stored at the special folder /usr/lib/systemd/system-sleep:
Koodi:
#!/bin/bash

if [ -f /etc/systemd/sleep.conf.bak ] && [ $1 == "post" ] && [ $2 == "hibernate" ]; then
  mv /etc/systemd/sleep.conf.bak /etc/systemd/sleep.conf
fi
The script in this folder will be run after hibernation with $1="post" and $2="hibernate" (see sleep.conf.d manpage) when resuming from hibernation, thus restoring the old sleep.conf.
Linuxiin paluun jälkeen "sleep.conf.bak" on edelleen tuolla kansiossa ja "sleep.conf":ssa on vain "[Sleep]\nHibernateMode=reboot" joka kirjoitetaan aiemmassa vaiheessa. "disable-hibernate-reboot" on tehty sudolla ja sille on annettu ajo-oikeudet mutta jostain syystä sitä ei ajeta kun tullaan hibernatesta takaisin linuxiin. Ihmeen hankala tämäkin oli vaikka näytti helpoilta ohjeilta.
 
Liittynyt
17.10.2016
Viestejä
617
Sudosta en edes ala arvailemaan mitään, mutta syystä taikka toisesta ilmeisesti jotkut distrot odottavat löytävänsä tiettyjä systemd-juttuja /lib/systemd-hakemiston alta tuon /usr/lib/systemd:n sijaan. Eli jos tuolta hakemistosta ei ajeta ja /lib/systemd/system-sleep hakemisto löytyy, niin kokeile siirtää sinne. Ja muista chmod +x.
 
Liittynyt
17.10.2016
Viestejä
425
sudon salasana kyselystä pääsee eroon kun laittaa /etc/sudoers tiedoston perään seuraavan rivin:
<user> ALL=(ALL) NOPASSWD:ALL
<user> tilalle oma käyttäjätunnus.
Tämä poistaa sitten salasana kyselyn aina sudoa käytettäessä.
 
Liittynyt
18.10.2016
Viestejä
32
Toimiiko skriptin ajo sudon kanssa komentoriviltä? Auttaisko seuraava muutos:
Koodi:
fubar ALL=(ALL:ALL) NOPASSWD: /home/fubar/.bin/hibernate_and_reboot_to_windows.bash
->
fubar ALL=(ALL) NOPASSWD: /home/fubar/.bin/hibernate_and_reboot_to_windows.bash
 
Liittynyt
12.06.2018
Viestejä
200
Kannattaa lisäksi alkaa käyttää niitä .d-päätteisiä hakemistoja noihin omien konffien lisäilyyn. Eli älä muokkaa distron asentamaa /etc/sudoers-tiedostoa, vaan tee /etc/sudoers.d-hakemistoon uusi järkevän niminen tiedosto, johon laitat noi omat muutokset. Näin pysyy distron konffikset siistinä ja päivittyvät edelleen automaattisesti. Aika moni palvelu mahdollistaa jo tämän vastaavan tavan.
 
Liittynyt
20.10.2016
Viestejä
2 122
Mielenkiintoista vaan, että kun kovasti on ensin puhuttu tietoturvasta ja joistakin "puutteista" Linuxissa ja nyt sitten halutaan työpöydälle mahdollisuus ajaa skripti root oikeuksilla ilman mitään kyselyjä...
 
Liittynyt
17.10.2016
Viestejä
1 547
Eli jos tuolta hakemistosta ei ajeta ja /lib/systemd/system-sleep hakemisto löytyy, niin kokeile siirtää sinne.
Tämä ratkaisi homman, kiitoksia.

sudon salasana kyselystä pääsee eroon kun laittaa /etc/sudoers tiedoston perään seuraavan rivin:
<user> ALL=(ALL) NOPASSWD:ALL
<user> tilalle oma käyttäjätunnus.
Tämä poistaa sitten salasana kyselyn aina sudoa käytettäessä.
Tarkoitus ei ollut antaa täysiä oikeuksia tehdä mitä vaan. Ainoastaan vain yhden skriptin ajaminen halutaan sallituksi.

Selvisi miksi sudoers:iin laittamani rivi ei toiminut. Lisäsin alunperin rivin "User privilege specification" kommentoinnin ja sen alla olevan root ALL=(ALL:ALL) ALL rivin alle. Jostain kumman syystä tuohon paikkaan kun laittoi mitä vain, vaikka kaikki sallituksi tietylle käyttäjälle, niin se ei toimi jostain syystä. Oman lisäyksen jos laittaa ihan viimeiseksi riviksi niin sitten alkaa toimimaan.

Kannattaa lisäksi alkaa käyttää niitä .d-päätteisiä hakemistoja noihin omien konffien lisäilyyn.
Ja taas opitaan lisää. Kiitos. Teen tuolle sudoers-jutulle tuon ja myös sleep.conf:lle. Katsoin manuaalia ja siellä on listattu näin:
Koodi:
/etc/systemd/sleep.conf
  /etc/systemd/sleep.conf.d/*.conf
  /run/systemd/sleep.conf.d/*.conf
  /usr/lib/systemd/sleep.conf.d/*.conf
Mitähän noista sleep.conf.d-kansioista kannattaisi käyttää? Mitään noista sleep.conf.d-kansioita ei löydy.

Mielenkiintoista vaan, että kun kovasti on ensin puhuttu tietoturvasta ja joistakin "puutteista" Linuxissa ja nyt sitten halutaan työpöydälle mahdollisuus ajaa skripti root oikeuksilla ilman mitään kyselyjä...
"Yhdelle käyttäjälle annetaan lupa ajaa yksi oma skriptitiedosto ilman sudoa jossa vain pari komentoa" vertautuu "monissa *nix:issa kaikkien käyttäjien annetaan lukea kaikkien toisten tiedostot" miten?
 
Liittynyt
20.10.2016
Viestejä
2 122
"Yhdelle käyttäjälle annetaan lupa ajaa yksi oma skriptitiedosto ilman sudoa jossa vain pari komentoa" vertautuu "monissa *nix:issa kaikkien käyttäjien annetaan lukea kaikkien toisten tiedostot" miten?
Kyllä tuossa piilee vaaroja, kunhan vaan ihmettelin, ku niin tarkka muuten on tietoturvasta, mutta oma on koneesi ja saat tehdä niinkuin haluat, eipä mulla sen enempää tästä...
 
Liittynyt
17.10.2016
Viestejä
1 547
Kyllä tuossa piilee vaaroja, kunhan vaan ihmettelin, ku niin tarkka muuten on tietoturvasta
Henkilökohtainen tietoturva on AINA tasapainottelua käytettävyyden ja turvallisuuden välillä. Jos en tuota skriptitiedostoa lähde muuttamaan käsin niin en itse ainakaan tiedosta mitään vaaroja. Onko niitä?
 
Liittynyt
17.10.2016
Viestejä
1 547
Tein ohjeet tuolle "hibernate ja reboottaa windowsiin" hommallle, laitan sen tähän jos jotakuta kiinnostaa. Hibernate pitää olla erikseen säädetty toimimaan (siitäkin tein ohjeen, voin postata senkin jos jotakuta kiinnostaa). Huom! Ohje on markdown-syntaksilla (eli esim. 1 tai 3 backtick-merkkiä ( ` tai ``` ) merkkaa koodia ja niitä ei pidä copypastettaa).

**This has been tested to work with Linux Mint 20 Cinnamon.**

# 1. Create script

Create a new hidden `.bin` folder (if it doesn't exist) in your home folder for script files:

`[[ ! -d "$HOME/.bin" ]] && mkdir "$HOME/.bin"`

Create a new script file in the folder:

`touch "$HOME/.bin/hibernate_and_reboot_to_windows.bash"`

Restrict permissions and set execute permission for the file:

`chmod 0700 "$HOME/.bin/hibernate_and_reboot_to_windows.bash"`

Add the following code to the file:

```
#!/bin/bash

# Configure the system to reboot after hibernate.
# This script is going to be run with root privileges so no sudo is needed.

# Create a folder for the sleep.conf if it doesn't exist yet.
[[ ! -d "/etc/systemd/sleep.conf.d" ]] && mkdir "/etc/systemd/sleep.conf.d"

# Create a new sleep.conf configuration file.
touch "/etc/systemd/sleep.conf.d/hibernate_mode_reboot.conf"

# Write configuration to the file.
printf "[Sleep]\nHibernateMode=reboot" > "/etc/systemd/sleep.conf.d/hibernate_mode_reboot.conf"

# Configure system to boot to Windows OS just once.
# Automatically finds the correct boot entry code for Windows.
efibootmgr --bootnext "$( efibootmgr | grep -i windows | cut -c 5-8 )"

# Start hibernate
systemctl hibernate
```


# 2. Sudo permissions for the script

Create a new file that will be imported to sudoers file automatically:

`sudo touch "/etc/sudoers.d/hibernatescript"`

Restrict permissions for the file:

`sudo chmod 0440 "/etc/sudoers.d/hibernatescript"`

Open the file with visudo (always use visudo for editing sudoers files!):

`sudo visudo -f "/etc/sudoers.d/hibernatescript"`

Add the following line (change BOTH "username" strings to your actual username!):

`username ALL=(ALL:ALL) NOPASSWD: /home/username/.bin/hibernate_and_reboot_to_windows.bash`

Save the file with `CTRL+S`, and exit with `CTRL+X`


# 3. Configure system-sleep

Create a new script file to control the `sleep.conf` file created in `hibernate_and_reboot_to_windows.bash` script file:

`sudo touch "/lib/systemd/system-sleep/disable_hibernate_reboot"`

Restrict permissions and set execute permission for the file:

`sudo chmod 0700 "/lib/systemd/system-sleep/disable_hibernate_reboot"`

Add the following code to the file (open file as root):

```
#!/bin/bash

#
if [[ -f "/etc/systemd/sleep.conf.d/hibernate_mode_reboot.conf" && "$1" == "post" && "$2" == "hibernate" ]]
then
rm "/etc/systemd/sleep.conf.d/hibernate_mode_reboot.conf"
fi
```


# 4. Create a launcher on the desktop

Right-click on your desktop and choose "Create a new launcher here..."

Add the following properties to the launcher (change "username" string to your actual username!):

Name = Boot to Windows
Command = sudo "/home/username/.bin/hibernate_and_reboot_to_windows.bash"

Change the the icon of the launcher by clicking the rocket icon. Search with "microsoft" (without quotes) and select the familiar microsoft windows icon for the launcher.


That's all! Double-clicking the "Boot to Windows" launcher will instantly hibernate linux and boot straight to Windows.
 
Liittynyt
17.10.2016
Viestejä
1 547
Mitenkäs olette ratkaisseet bios-kellon vaihtumisen dual-bootatessa? Windows tykkää käyttää paikallista aikaa, linux UTC:tä. Eli bios:in kello vaihtuu jatkuvasti dual-boottaillessa ja kellonajat käyttiksissä ovat jatkuvasti pielessä. Kumpaan käyttikseen kannattaisi tehdä muutos jotta tätä ei tapahdu. Yritin googlata mutta jotkut sanoo, että säädä windows käyttämään UTC:tä, toiset että säädä linux käyttämään paikallista aikaa. Onko sillä mitään väliä kumpaa kautta fiksaa ongelman?
 
Liittynyt
19.10.2016
Viestejä
1 504
Mitenkäs olette ratkaisseet bios-kellon vaihtumisen dual-bootatessa? Windows tykkää käyttää paikallista aikaa, linux UTC:tä. Eli bios:in kello vaihtuu jatkuvasti dual-boottaillessa ja kellonajat käyttiksissä ovat jatkuvasti pielessä. Kumpaan käyttikseen kannattaisi tehdä muutos jotta tätä ei tapahdu. Yritin googlata mutta jotkut sanoo, että säädä windows käyttämään UTC:tä, toiset että säädä linux käyttämään paikallista aikaa. Onko sillä mitään väliä kumpaa kautta fiksaa ongelman?
Jos distrohoppailet paljon niin on varmaan helpoin tehdä muutos windowssiin niin ei tarvitse jokaisen distron asennuksen jälkeen säätää.
 
Liittynyt
12.06.2018
Viestejä
200
Mitenkäs olette ratkaisseet bios-kellon vaihtumisen dual-bootatessa? Windows tykkää käyttää paikallista aikaa, linux UTC:tä. Eli bios:in kello vaihtuu jatkuvasti dual-boottaillessa ja kellonajat käyttiksissä ovat jatkuvasti pielessä. Kumpaan käyttikseen kannattaisi tehdä muutos jotta tätä ei tapahdu. Yritin googlata mutta jotkut sanoo, että säädä windows käyttämään UTC:tä, toiset että säädä linux käyttämään paikallista aikaa. Onko sillä mitään väliä kumpaa kautta fiksaa ongelman?
Jännä, että aina kun näistä etsii tietoa, niin melkein poikkeuksetta paras dokumentti ja ohje tulee vastaan archlinuxin wikistä. System time - ArchWiki
 
Liittynyt
01.02.2017
Viestejä
617
Mitenkäs olette ratkaisseet bios-kellon vaihtumisen dual-bootatessa? Windows tykkää käyttää paikallista aikaa, linux UTC:tä. Eli bios:in kello vaihtuu jatkuvasti dual-boottaillessa ja kellonajat käyttiksissä ovat jatkuvasti pielessä. Kumpaan käyttikseen kannattaisi tehdä muutos jotta tätä ei tapahdu. Yritin googlata mutta jotkut sanoo, että säädä windows käyttämään UTC:tä, toiset että säädä linux käyttämään paikallista aikaa. Onko sillä mitään väliä kumpaa kautta fiksaa ongelman?
Mulla on wintous universaalissa ajassa. Ei oo linuxin vika tuollainen ;)
 
Liittynyt
21.06.2017
Viestejä
4 270
Sudosta en edes ala arvailemaan mitään, mutta syystä taikka toisesta ilmeisesti jotkut distrot odottavat löytävänsä tiettyjä systemd-juttuja /lib/systemd-hakemiston alta tuon /usr/lib/systemd:n sijaan. Eli jos tuolta hakemistosta ei ajeta ja /lib/systemd/system-sleep hakemisto löytyy, niin kokeile siirtää sinne. Ja muista chmod +x.
Niin tai siis /lib/systemd kansioon menee kaikki systeemin asentamat rojut eli siis yleensä pakettien ja nämä on sellaisia joita käyttäjän ei tulisi koskaan muutella koska seuraavassa pakettipäivityksessä muutokset suurella todennäköisyydellä katoaa.
Sitä varten on /etc/systemd jonne käyttäjä konffit ja muutokset menee.
 
Liittynyt
17.10.2016
Viestejä
617
Niin tai siis /lib/systemd kansioon menee kaikki systeemin asentamat rojut eli siis yleensä pakettien ja nämä on sellaisia joita käyttäjän ei tulisi koskaan muutella koska seuraavassa pakettipäivityksessä muutokset suurella todennäköisyydellä katoaa.
Sitä varten on /etc/systemd jonne käyttäjä konffit ja muutokset menee.
Kyllä, käyttäjän konffit ja overridet menevät /etc/systemd:hen. Mutta kyse olikin system-sleep scripteistä ja ellei Lennart Poettering ole pyörtänyt viimeaikoinaan päätöstään olla tukematta mitään executableja /etc:n alla niin ei ne scriptit siellä paljoa lämmitä.

Vrt. Add support for /usr/local/lib/systemd/system-sleep/ · Issue #4927 · systemd/systemd
 
Liittynyt
21.06.2017
Viestejä
4 270
Kyllä, käyttäjän konffit ja overridet menevät /etc/systemd:hen. Mutta kyse olikin system-sleep scripteistä ja ellei Lennart Poettering ole pyörtänyt viimeaikoinaan päätöstään olla tukematta mitään executableja /etc:n alla niin ei ne scriptit siellä paljoa lämmitä.

Vrt. Add support for /usr/local/lib/systemd/system-sleep/ · Issue #4927 · systemd/systemd
Ja ihan oikeassa se on. Ajettavat tiedostot kuuluu muualle, koska porukka tekee varsin villejä virityksiä kuten noexec mountattua /etc jne...
 
Liittynyt
17.10.2016
Viestejä
617
Ja ihan oikeassa se on. Ajettavat tiedostot kuuluu muualle, koska porukka tekee varsin villejä virityksiä kuten noexec mountattua /etc jne...
No, SysV init scriptit ovat aika kauan majailleet /etc/init.d:ssä. Siinä kun mounttailee noexecinä, voipi iskeä masis.
Ei sillä että olisin eri mieltä, mutta systemd lasien läpihan Poettering asian näkee.
 
Toggle Sidebar

Statistiikka

Viestiketjut
102 950
Viestejä
2 066 807
Jäsenet
42 414
Uusin jäsen
Tapalni

Hinta.fi

Ylös Bottom