Crowtail MOSFET ei anna jännitettä (micro:bit)

Viestiketju alueella 'Elektroniikka, rakentelu ja muut DIY-projektit' , aloittaja tatup, 14.01.2020.

  1. tatup

    tatup

    Viestejä:
    14
    Rekisteröitynyt:
    27.04.2017
    [​IMG]


    täysi aloittelija näissä hommissa, löytyisiköhän täältä apuja?

    Saan kyllä esim ledin palamaan ihan ok, mutta samasta portista mosfetin käskytys ei tunnu onnistuvan. Kytken siis micro:bitin mosfetiin, ja VIN näyttää 3 volttia. VOUT näyttää 0. Nyt oletin, että jos laitan saman pinnin ykköseksi (pin1.write_digital(1) pythonilla), niin VOUTtiin tulisi 3 volttia, mutta näin ei käy. Jos VINnisä olisi esim 9v patteri, en ole varma mitä VOUTissa pitäisi olla?

    Minulla on varmaan joku ajatusvirhe tässä koko hommassa, auttakoon ken kykenee.
     
  2. Lassivv

    Lassivv Tukijäsen Team H2O

    Viestejä:
    964
    Rekisteröitynyt:
    12.02.2017
    Varmaan helpottaa jos nyt piirtää ihan täysin johdolleen miten tuon oot kytkenyt.

    Vin:5~50V näyttäisi speksi sivut eli 3volttia sinne on turha tarjoilla.

    Se että onko mikron kytkennät oikein yms vähän epäilyttää, että sikäli tuo piirretty kuva kytkikestä antaa varmaan vastauksia. Jos Vin laittaa 9volttia niin voutista tulee luonnollisesti 9volttia tai hieman alle 9volttia häviöt huomioiden mutta näin kuitenkin suurinpiirtein.
     
  3. tatup

    tatup

    Viestejä:
    14
    Rekisteröitynyt:
    27.04.2017
    20200114_220012 - Copy.jpg
    Toivottavasti tuosta selviää? Laitoin VINniin nyt 9v patterin ja 9v siitä näkyy porttiin tulevankin.Vouttiin ei tule mitään jännitettä. Olen yrittänyt sitä vaihtaa diginä 1 ja 0, analogisena 0, 255 ja 1023 arvoihin mutta nollaa näyttää. Kiitos kovasti avusta!