Bluetooth rikki Z390-emolevyssä?

Liittynyt
09.01.2017
Viestejä
497
Hei io-techiläiset, taitaa olla vasta toinen kerta, kun tarvitsen tämän palstan apuja. Eli epäilen Z390-emolevyssä rautapohjaista vikaa, sillä koneessa toimi bluetooth eilen keskipäivällä aivan normaalisti Sonyn bt-kuulokkeiden kanssa, mutta illalla uudelleen käynnistyksen jälkeen ei toiminut, vaan bluetooth on kadonnut niin Windowsin laitehallinnasta kuin Bluetooth-asetuksistakin Windows 10:n uudessa ohjauspaneelissa.

Rautavikaa puoltavat seikat:
- Konetta käynnistäessä koneella kestää 21-22 sekuntia Asus ROG-logon kohdalla, ennen kuin siirrytään itse Windows 10:n lataamiseen SSD:ltä. Mielestäni 20 sekunnin kesto ROG-logon kohdalla viittaa vikaan tai ristiriitaan, jonka vuoksi ei etene kuten muilla UEFI-pohjaisilla koneilla (esim. omani X99-pohjainen), jossa aikaa menee max 5 sekuntia.
- Laitehallintaan ilmestyy Tuntematon USB-laite (laitekuvainpyyntö epäonnistui), vaikka sen poistaisi ja reboottaisi koneen uudelleen. Eli sama "vikaantunut" USB-ohjain ilmestyy aina vain takaisin.
- On kokeiltu USB-laitteiden poistoa (Web-kamera ja langattomien kuulokkeiden tikun (Corsair HS 70 Pro tms.) poisto, sekä vaihdettu eri näppäimistöön ja kokeiltu tätä vaihtonäppäimistöä ja langattoman hiiren käyttöä eri USB-porteissa). Tällä ei ole vaikutusta tuon tuntemattoman USB-laitteen uudelleen tulemiseen laitehallintaan.
- Bluetooth/WiFi on Biosissa edelleen aktivoituna, eli ei ole mystisesti kytkeytynyt pois päältä BIOS:sta.
- Asuksen sivuilta ladattu Bluetooth-ajuri ei avaudu lainkaan, vaikka avataan Asuksen Setup.exe. Viittaisiko tämä siihen, että asennusikkunaa ei tule, kun ei ole mitään ajuripaketille havaittavaa laitetta koneessa?

Lisäksi Windows Updaten päivityshistoriassa ei ole tällä viikolla tehty mitään ajuripäivitystä tai merkittävää OS-päivitystä. Ainoa päivitys eiliseltä oli virustunnisteet Defenderille. Vaikea siis uskoa, että jokin Windowsin päivitys olisi asiaan syyllinen tai muu vinossa oleva bitti Windowsissa.

Mielestäni emolla on siis käynyt harvinainen, muttei tavaton vikaantuminen - bluetooth on kuollut, kuten joillakin on ihmeellisesti mykistynyt koneen verkkokortti tai äänikortti. Erityisesti tuo ROG-logon kohdalla tapahtuva hidastelu (+20 sekuntia se ruutu), viittaa johonkin rautavikaan.

Millaisia ajatuksia teillä tulee tästä? Emolevynä Asus Z390-E Strix Gaming ja muutoin 16 Gt DDR4-4000, Core i9 9900K ja RTX2060.

Varalta löytyy yksi toimiva Z370-F Strix Gaming vaihdoksi (F-malleissa ei bluetoothia) tai sitten menee tällä (hitaalla ROG-logobuutilla). Molemmissa tapauksissa tarvittaisiin erillinen bluetooth-laite, jotta saadaan bluetooth takaisin käyttöön.
 

Liitteet

Liittynyt
18.03.2017
Viestejä
483
Jos tuplaklikkaat tuota "tuntematonta laitetta" laitehallinnassa, sitten menet Tiedot-välilehdelle ja valitset sieltä pudotusvalikosta "Laitteistotunnukset", mitä tulee näkyviin?

Pitäisi tulla suunnilleen tämännäköinen rimpsu: USB\VID_xxxx&PID_yyyy&REV_zzzz
jossa:
xxxx = VID = Vendor ID = valmistajatunnus
yyyy = PID = Product ID = laitetunnus
zzzz = revision = malliversion tunnus (autojen kanssa sanottaisiin "vuosimalli")

Jokaisella USB-laitteella pitäisi olla nelinumeroiset VID- ja PID-tunnukset, joiden avulla laitteen tyyppi voidaan tunnistaa.
VID on valmistajatunnus, ja PID on valmistajakohtainen laitetunnus. Näitä tunnuksia voi etsiä vaikkapa tuolta: The USB ID Repository

Jos noita tunnuksia ei tule näkyviin tai ne ovat esim. pelkkiä nollia tai FFFF:iä, se on aika vahva vihje että ko. laitteessa on joko firmis- tai rautaperäistä vikaa.
Mutta jos tunnukset näkyvät oikein, se ei vielä anna laitteelle täyttä synninpäästöä: se voi silti olla viallinen.

Toinen tapa varmistua asiasta voisi olla kytkeä Bluetooth BIOSista pois päältä. Häviääkö tällöin "tuntematon laite" näkyvistä laitehallinnasta?

Emolle integroitu bluetooth on usein samassa piirissä integroidun WiFi:n kanssa, joten bluetooth-vika saattaa ennakoida vaikeuksia myös WiFi-puolen kanssa. Lisäksi koska Bluetooth ja 2.4 GHz WiFi käyttävät samaa taajuuskaistaa, integroitu bluetooth ja WiFi on yleensä kytketty yhteen siten että ne eivät lähetä päällekkäin samaan aikaan samalla taajuudella: tästä voi joskus seurata se, että jos WiFi on laitettu pois päältä/ajureita ei ole ladattu, myöskään Bluetooth ei toimi.

Jos bluetooth ei tunnu heräävän henkiin, ja koneessa on yksi vapaa USB-portti, helpoin ratkaisu voisi olla laittaa BIOSista tuo integroitu Bluetooth pois päältä ja hankkia erillinen USB-Bluetooth-palikka: ne eivät paljoa maksa.

Jos tuollaisen USB-Bluetooth-palikan mukana tulee (tai romulaatikon pohjalta löytyy) lyhyt USB-jatkojohto, saattaa olla hyvä laittaa se koneen ja USB-Bluetooth-palikan väliin: näin saadaan Bluetooth-vastaanotin vähän etäämmäksi USB3-kaapeleista, jotka saattavat vuotaa häiriöitä samalle 2.4 GHz taajuuskaistalle jota Bluetooth käyttää. Tällaisilla häiriöillä on yleensä hyvin lyhyt kantomatka, joten 5-10 senttiä pitkällä USB-jatkojohdolla voi olla merkitystä Bluetoothin toiminnan kannalta.
 
Liittynyt
09.01.2017
Viestejä
497
Kiitos, kattava aloituspostaus sai arvoisensa vastauksen. Kävin katsomassasi pyytämäsi laitteistotunnukset-kohdan laitehallinnasta tämän vikaantuneen USB-kohteen osalta.

Näkyvissä on vain USB\DEVICE_DESCRIPTOR_FAILURE

Eli ei ole mitään tunnuksia, eikä nollia tai FFF:iä.

Testasin myös BIOS:ista kytkemällä pois Wifin ja Bluetoothin (ovat siis samaa bios-asetusta, koska toiminnot sijaitsee samalla piirillä). Kun kytkin biosista nämä emon langattomat ominaisuudet pois päältä, niin laitehallinnassa ei enää näy tuota virheellistä eli tuntematonta USB-laitetta lainkaan.

Ehdin hankkia veljelle jo tuollaisen USB-pohjaisen bluetooth-palikan (20€), joten luultavasti mennään sitten emon omien langattomien piirien osalta offilla jatkossakin. Erillinen USB-pohjainen bluetooth tuntuisi toimivan varsin hyvin noiden Sonyn suosittujen Sony Wh1000XM3-kuullokeiden kanssa.

Testaan vielä kytkemällä langattomat ominaisuudet emon piiriltä vielä kerran päälle, mutta näillä näkymin on selvää, että "tuntematon" USB-laite palannee tuon enabloinnin jäljeltä.

Harmillisesti takuu on ehtinyt mennä emolla loppuun, koska ostettu keväällä 2019... Juuri sopivasti menty sen 3 vuoden takuun ylitse.

Miltä siis kuulostaa tuo laitteistotunnus, kun ei ole edes nollia tai FFF:iä?
 

Liitteet

Liittynyt
09.01.2017
Viestejä
497
Joo, kokeilin vielä aktivoida emon bluetoothia päälle, ja laitteen tapahtumat välilehdellä lukee:

"Device USB\VID_8087&PID_0AAA\5&38e97a59&0&14 had a problem starting." sekä

"Problem: 0x1F
Problem Status: 0xC0000001"

Taitaa olla tämä tapaus siis taputeltu. USB:llä mennään sitten.
 
Liittynyt
18.03.2017
Viestejä
483
Näkyvissä on vain USB\DEVICE_DESCRIPTOR_FAILURE
Eli Windows tunnisti että edes laitetunnisteen lukeminen ei onnistunut, ja näköjään osaa kertoa sen tuolla tavalla. Vikaahan se tarkoittaa.

Toisen yrityksen tulos USB\VID_8087&PID_0AAA\5&38e97a59&0&14 näyttää siltä että tunnisteen lukeminen sillä kertaa onnistui, mutta sitten tuli laitteen käynnistyksessä jotain muuta pulmaa. Vaikuttaa siis siltä että vian luonne voisi olla jonkinlainen Bluetooth-moduulin virransyötön tai USB-datayhteyden pätkiminen.

VID 8087 = Intel, ja Intelin tuotteissa PID = 0AAA viittaa Wireless-AC 9460 tai 9560-malliseen WiFi-piiriin integroituun Bluetooth-toiminnallisuuteen, eli saatu tunniste näyttää järkevältä:

Samaa koodia saattaa olla uudelleenkäytetty muidenkin uudehkojen Intelin WiFi-piirien Bluetooth-toteutuksissa, jos Bluetooth-puolen toteutus on täsmälleen sama.

Jos tuo WiFI+Bluetooth-moduuli olisi näkösällä omassa Mini-PCI, M.2 tai vastaavassa paikassa emolevyn pinnalla, voisi ehkä kokeilla moduulin irrotusta ja uudelleen kiinnitystä, siltä varalta että ongelma olisi jonkinlainen kontaktien hapettumisen aiheuttama kosketushäiriö. Mutta tuossa emossa tuo moduuli taitaa olla haudattuna jonnekin muovisuojien alle piiloon niin, että sen esille saamiseksi pitäisi irrottaa emolevy ja siitä muovisuojat ennen kuin edes näkee onko moduuli irrotettavissa vai ei... ei taida olla vaivan arvoista, varsinkin jos WiFi-puoli toimii normaalisti (tai sille ei ole tarvetta ollenkaan).
 

Satelite

Tukijäsen
Liittynyt
20.04.2017
Viestejä
2 115
Tuohon pitkään käynnistykseen voisit kokeilla pistää muistille sopivat asetukset emoon ns. manuaalilla eli jos automaatilla muistin asetukset niin heitäs manuaalisesti sinne 1:1 muistien kanssa sopivat asetukset. Eli esim. muistin taajuus. Tämä ehkä saattaisi auttaa myös bluetooth ongelmaan mutta selviää vaan kokeilemalla.
 
Liittynyt
17.10.2016
Viestejä
18 467
Todennäköisesti ison siilin alla on irrallinen kortti m.2 key E -paikassa, jonka voi vaihtaa.

Todennäköisesti tuollaisella lähtisi taas toimimaan:

Voi kyllä samalla katsoa, miksi se on lakannut toimimasta yht'äkkiä. Onko emolevylle tapahtunut mitään fyysistä viime aikoina?
Voi kyllä sekin taas johtua kuumista lämmöistä, jota tuolla on, jotka ei joidenkin mielestä ollenkaan ole pahasta komponenteille. /sarkasmi
 

Satelite

Tukijäsen
Liittynyt
20.04.2017
Viestejä
2 115
Todennäköisesti ison siilin alla on irrallinen kortti m.2 key E -paikassa, jonka voi vaihtaa.

Todennäköisesti tuollaisella lähtisi taas toimimaan:

Voi kyllä samalla katsoa, miksi se on lakannut toimimasta yht'äkkiä. Onko emolevylle tapahtunut mitään fyysistä viime aikoina?
Voi kyllä sekin taas johtua kuumista lämmöistä, jota tuolla on, jotka ei joidenkin mielestä ollenkaan ole pahasta komponenteille. /sarkasmi

Ennemmin laittaisin AX210 piirin niin saa 6GHz tuen ja WIFI6E tuen myös.
 
Liittynyt
09.01.2017
Viestejä
497
Tuohon pitkään käynnistykseen voisit kokeilla pistää muistille sopivat asetukset emoon ns. manuaalilla eli jos automaatilla muistin asetukset niin heitäs manuaalisesti sinne 1:1 muistien kanssa sopivat asetukset. Eli esim. muistin taajuus. Tämä ehkä saattaisi auttaa myös bluetooth ongelmaan mutta selviää vaan kokeilemalla.
Tuo pitkä käynnistysaika BIOS:ssa poistui, kun otti Bluetoothin ja Wifin-kokonaisuuden pois käytöstä BIOS:sta. Eli en usko, että RAM-muistit ovat tässä tapauksessa ongelma, sillä PC on toiminut ennen ja jälkeen Bluetooth-vian ihan hyvin samaisilla RAM-asetuksilla. Lisäksi kone on läpäissyt myös KarhuSoftwaren muistitestit aiemmin hyvin.

Todennäköisesti ison siilin alla on irrallinen kortti m.2 key E -paikassa, jonka voi vaihtaa.

Todennäköisesti tuollaisella lähtisi taas toimimaan:

Voi kyllä samalla katsoa, miksi se on lakannut toimimasta yht'äkkiä. Onko emolevylle tapahtunut mitään fyysistä viime aikoina?
Voi kyllä sekin taas johtua kuumista lämmöistä, jota tuolla on, jotka ei joidenkin mielestä ollenkaan ole pahasta komponenteille. /sarkasmi
Ilmeisesti operaatio olisi vastaavanlainen kuin tässä Redditin ketjussa. Oman emolevyni manuaali kertoo, että Wifi-kortin kohdalla piirikuvassa lukee (CNVI(Wifi)). Tuo CNVI siis viittaa siihen, että kyseessä on tosiaan m.2-pohjainen kortti.

Tuosta AX210:ä ei ole mainittu Intelin mainitsemalla sivulla, eli onko tuolla CNVi:llä merkitystä tässä tapauksessa?

Eli voisin toki tätä askartelua harkita, lähinnä mietityttää tuo muovinen kuori, joka on näiden liitinpaneelistojen päällä. Nehän on yleistyneet nykyään, mutta onko sen poistaminen väliaikaisesti iso asia?

Kortin Wifi-puoli näyttäisi tosiaan toimivan, koska se löytää ilmassa olevat Wifi-verkot, mutta Bluetooth ei ole palannut toimintaan. Joten kortti on vaihdettava, ellemme jatka sitten USB-pohjaisella ratkaisulla, joka toimii ihan jees.

Voisikohan hsalosen kuumentumisepäilyyn liittyä se, että emossa on kiinni Core i9 9900K ja jäähdyttimenä on NH-U12P, joka ei siten coolerin mallin vuoksi aiheuta ilmavirtaa lämmönsyötölle ja emolevyn pinnalle?

Joka tapauksessa harmittava vikaantuminen, vaikka asia on nyt korjattuna USB-pohjaisella ratkaisulla. Luultavasti fiksaisin tämän sitten, jos emo lähtee kiertoon toiseen koneeseen joskus tulevina vuosina, jos päivitetään tätä pelikonetta parempaan rautaan sitten.
 
Liittynyt
17.10.2016
Viestejä
18 467
Ilmeisesti operaatio olisi vastaavanlainen kuin tässä Redditin ketjussa. Oman emolevyni manuaali kertoo, että Wifi-kortin kohdalla piirikuvassa lukee (CNVI(Wifi)). Tuo CNVI siis viittaa siihen, että kyseessä on tosiaan m.2-pohjainen kortti.
Joo, paitsi itsellä ei ollut tuollaista metalliboxia ympärillä; se on aika turha.. Siis se on todennäköisesti suojana, että ei tulee elektromagneettista häiriötä vierestä, mutta kelat on koteloitu ja ihan hyvin noi toimii ilman tuollaisia virityksiä.

Tuosta AX210:ä ei ole mainittu Intelin mainitsemalla sivulla, eli onko tuolla CNVi:llä merkitystä tässä tapauksessa?
AX210 on Wifi 6E ja tuoreempi tapaus. @Satelite varmaan tarkoitti, että kun päivität, kannattaa suoraan tuoreempaan versioon , eikä "vanhaan" AX200:n. Itsellä ei ole AX210 vielä missään, mutta on yksi ostettuna.
Ei varmaan manuaalin kirjoittamisen hetkellä ollut tuotetta olemassa, mutta jos se on M.2 Key E, pitäisi toimia suoraan. Ei nuo Asuksen emolevyt ole BIOS-rajoitettuja, eivätkä muutkaan, poislukien pakettikoneet.

Eli voisin toki tätä askartelua harkita, lähinnä mietityttää tuo muovinen kuori, joka on näiden liitinpaneelistojen päällä. Nehän on yleistyneet nykyään, mutta onko sen poistaminen väliaikaisesti iso asia?

Kortin Wifi-puoli näyttäisi tosiaan toimivan, koska se löytää ilmassa olevat Wifi-verkot, mutta Bluetooth ei ole palannut toimintaan. Joten kortti on vaihdettava, ellemme jatka sitten USB-pohjaisella ratkaisulla, joka toimii ihan jees.

Voisikohan hsalosen kuumentumisepäilyyn liittyä se, että emossa on kiinni Core i9 9900K ja jäähdyttimenä on NH-U12P, joka ei siten coolerin mallin vuoksi aiheuta ilmavirtaa lämmönsyötölle ja emolevyn pinnalle?
En sano tuohon Noctuaan muuta, kuin että alitehoinen prosessorijäähy tuskin on syynä on tähän. Siinä on enemmänkin edessä sitä muoviroinaa. Ja ehkä se on metalliboxissa, jossa se kuumenee. Nuo kuumenee käytössä ja joku malli on häirinnyt NUC:in SSD:tä, kun kuumeni niin paljon (ja oli siinä vieressä). Tästä opittiin ja se voi olla joskus 2015, mutta näin on tapahtunut.

Kahdesta emolevystä olen ottanut sen muovikoristeen pois, joka näyttää virransyötön siililtä. Nyt en enää jaksa. Se on täysin turha, mutta jos takuuta on jäljellä ja se on Jimm'siin, niin tod.näk. valittavat siitä, että olet parantanut ilmankiertoa. Jos takuuta ei ole jäljellä, siitä vaan toimiin ja tuskin rikot mitään. Jos siinä on ledit, sitten pitää olla varoivainen, mutta en itse ainakaan ole rikkonut vielä noita. Kahden muovihärpäkkeen kokemuksella. Asrockistakin olen sen poistanut, mutta pistin takaisin , kun olin asentanut wifi-kortin (joka oli paljaana siellä alla).

--

Lisäksi key-E adaptereita saa kaupasta, niin noita saa tavalliseen M.2-paikkaankin. Pitäisin vaan itse siinä mieluummin SSD:tä.
 

Satelite

Tukijäsen
Liittynyt
20.04.2017
Viestejä
2 115
Joo, paitsi itsellä ei ollut tuollaista metalliboxia ympärillä; se on aika turha.. Siis se on todennäköisesti suojana, että ei tulee elektromagneettista häiriötä vierestä, mutta kelat on koteloitu ja ihan hyvin noi toimii ilman tuollaisia virityksiä.



AX210 on Wifi 6E ja tuoreempi tapaus. @Satelite varmaan tarkoitti, että kun päivität, kannattaa suoraan tuoreempaan versioon , eikä "vanhaan" AX200:n. Itsellä ei ole AX210 vielä missään, mutta on yksi ostettuna.
Ei varmaan manuaalin kirjoittamisen hetkellä ollut tuotetta olemassa, mutta jos se on M.2 Key E, pitäisi toimia suoraan. Ei nuo Asuksen emolevyt ole BIOS-rajoitettuja, eivätkä muutkaan, poislukien pakettikoneet.



En sano tuohon Noctuaan muuta, kuin että alitehoinen prosessorijäähy tuskin on syynä on tähän. Siinä on enemmänkin edessä sitä muoviroinaa. Ja ehkä se on metalliboxissa, jossa se kuumenee. Nuo kuumenee käytössä ja joku malli on häirinnyt NUC:in SSD:tä, kun kuumeni niin paljon (ja oli siinä vieressä). Tästä opittiin ja se voi olla joskus 2015, mutta näin on tapahtunut.

Kahdesta emolevystä olen ottanut sen muovikoristeen pois, joka näyttää virransyötön siililtä. Nyt en enää jaksa. Se on täysin turha, mutta jos takuuta on jäljellä ja se on Jimm'siin, niin tod.näk. valittavat siitä, että olet parantanut ilmankiertoa. Jos takuuta ei ole jäljellä, siitä vaan toimiin ja tuskin rikot mitään. Jos siinä on ledit, sitten pitää olla varoivainen, mutta en itse ainakaan ole rikkonut vielä noita. Kahden muovihärpäkkeen kokemuksella. Asrockistakin olen sen poistanut, mutta pistin takaisin , kun olin asentanut wifi-kortin (joka oli paljaana siellä alla).

--

Lisäksi key-E adaptereita saa kaupasta, niin noita saa tavalliseen M.2-paikkaankin. Pitäisin vaan itse siinä mieluummin SSD:tä.
Itsellä oli ihan bolt-on päivitys kun päivitin Asuksen wifi+bt korttiin AX200 tilalle AX210. Windows tarjosi tuolle ajurit suoraan ja niillä menty eteenpäin. Updatesta tasaisin välein on tippunut välillä päivityksiä myös verkkopuolelle mutta enemmän bt on saanut päivityksiä. Edellisestä bt päivityksestä ei taida olla kuin ehkä viikko aikaa (välissä olin sairaalassa terveyssyistä niin muista päivälleen mutta tuota luokkaa kumminkin) Omasta mielestä ehkä hieman vakaampi yhteys AX210 kun vertaa AX200 mutta tässä tapauksessa tukiaseman välinen etäisyys on lyhyt niin hankala sanoa tarkempia kokemuksia mutta en itse lähtisi enää ottamaan wifi6 korttia jos wifi6e korttia saa jo todella halvalla (jimssillä tämä tais maksaa 20€ jos laskee ilman toimitusta)

Ainaskin Realtekin kikkareisiin verrattuna AX210 on paljon parempi saamaan vakaamman ja nopeamman yhteyden jos etäisyys tukiasemaan on isompi (tässä tapauksessa Deco X60 ikkunan takana kaapin päällä. välissä hieman pihapuustoa ja parkkipaikalla retkeilyauto jossa kortti kiinni läppärissä.) Kun vertasi Oneplus 8 PRO ja läppäriä mihin vaihdettu AX210 niin selvä ero oli AX210 eduksi.

Toiminut kuin vanhan junan vessa. 6GHz puolta en ole päässyt testaamaan kun ei ole siihen sopivaa tukaria mutta ostin kortin silti että on sillekkin valmius. Itse ainaskin 2.4GHz ja 5GHz puolen kokemuksilla uskallan enemmän kuin suositella kun muistelee mitä verkonkäyttö x laitteilla oli ennen kortin vaihtoa AX210.
 
Toggle Sidebar

Statistiikka

Viestiketjut
193 477
Viestejä
3 497 347
Jäsenet
62 350
Uusin jäsen
Maxfaraon

Hinta.fi

Ylös Bottom